Svetlana
?>

Домашнее задание №1 Написать программу для вычисления факториала с использованием цикла REPEAT. Домашнее задание №2 Задание для самостоятельной работы: Написать программу для вычисления суммы всех четных чисел на отрезке [M..N] с использованием цикла WHILE. язык БОЛЬШОЕ.

Информатика

Ответы

kuhonka2021

1) 2,375+(х+1,627)=4,56

    х+1,627=4,56-2,375

    х+1,627= 2,185

    x=2,185-1,627 

    x=0,558

проверка:   2,375+( 0,558 +1,627)=4,56 

                    2,375+2,185=4,56

                    4,56=4,56

ответ: х=0,558

2,а) 8,6-(х+2,75)=1,85         проверка: 8,6-(4+2,75)=1,85 

        х+2,75=8,6-1,85                           8,6-6,75=1,85

        х+2,75 =6,75                                 1,85=1,85

        х=6,75-2,75

        х=4 

      ответ: х=4

  2,б) 5,732+(х+7,269)=645     проверка: 5,732+( 631,999 +7,269)=645 

          х+7,269=645-5,732                         5,732+639,268=645

          х+7,269=639,268                           645=645

          х=631,999

ответ:   х=631,999

  2,в) 29,1-(х+7,08)=6-4,357   проверка: 29,1-( 20,377 +7,08)=6-4,357 

          29,1-(х+7,08)=1,643                         29,1-27,457=1,643

          х+7,08=29,1-1,643                           1,643= 1,643  

          х+7,08=27,457

          х=  27,457- 7,08

          х=20,377

ответ:   х=20,377

ГалинаРайгородская
Var 
a: array[1..n] of integer; 
k, i, m: byte; 
min: integer;

begin 
Write('Razmer massiva: '); 
Readln(k); 
if (k < 0) or (k > 100) then     
begin       
Writeln('Razmer dolzhen byt bolshe 0 i menshe 100');       
Readln;       
Exit;     
end; 
Randomize; 
Writeln('Ishodn. massiv: '); 
for i:=1 to k do     
begin       
a[i]:=Random(101)-50;       
write(a[i]:4);     
end; 
min:=a[1]; 
for i:=2 to k do   
if a[i] < min then       
begin         
min:=a[i];         
m:=i;       
end; 
a[m] := a[1]; 
a[1] := min; 
Writeln; 
Writeln('Min element = ', min:4, ' v posicii ', m:3); 
Writeln('Rezult. massiv: '); 
for i:=1 to k do     
write(a[i]:4); 
readln;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Домашнее задание №1 Написать программу для вычисления факториала с использованием цикла REPEAT. Домашнее задание №2 Задание для самостоятельной работы: Написать программу для вычисления суммы всех четных чисел на отрезке [M..N] с использованием цикла WHILE. язык БОЛЬШОЕ.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

lemoh
gub191025
whiskyandcola
Maly01984489
armsam76
Dmitrii836
msangelika1010
Исаченко Тераски1181
Vika-simonenko
Aleksandrivanovna
Староческуль-Станиславовна
alex091177443
likakedo4ka439
thedoomsdatdcs36
kzhgutova
▲