volkovaekaterina303
?>

с задачей. До начала каникул остаётся D дней. Определите сколько полных недель и сколько дней до начала каникул. Выделите операторы программы, необходимые для решения этой задачи.

Информатика

Ответы

Borg Fedak1162
Программа на языке PascalABC

program raf105;

var abc,ab,bc:integer;

begin

write('Введите трёхзначное число: ');

readln(abc);

ab:= abc mod 100;

bc:= abc div 10;

if ab = bc

 then writeln('Число состоит из одинаковых цифр')

 else writeln('Число не состоит из одинаковых цифр');

end.

Объяснение

Для выполнения задачи достаточно найти первые 2 цифры и последние 2 цифры если они равны, то число состоит из одинаковых цифр

abc mod 100 Убирает все сотни из числа.

Например было число 123, стало 23.

482 стало 82

abc div 10 Считает сколько в числе целых десяток, но не считает остаток.

Например было число 123, стало 12

482 стало 48

Сравнивание 2 первых и 2 последних цифр

253      25 и 53 не равны, значит число не состоит из одинаковых цифр

121       12 и  21 не равны, значит число не состоит из одинаковых цифр

111        11 и 11  равны, значит число состоит из одинаковых цифр

Иванович
Мультимедиа сейчас - это полноценное объединение компьютерных и других информационных технологий: видео, аудио, фото, кино, телекоммуникаций (телефон, телевидение, радиосвязь), не говоря уже о тексте и графике, как статической, так и динамической (анимационной). с приложений мультимедиа текст, графика, аудио- и видеоинформация объединяются в единое информационное поле, подобно тому как в кинофильме объединяются звук и движущееся изображение. однако в отличие от кинофильма мультимедиа представляет собой интерактивную среду, т. е. пользователь может процессом представления мультимедиа с различных средств ввода, таких как клавиатура и манипулятор мышь.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

с задачей. До начала каникул остаётся D дней. Определите сколько полных недель и сколько дней до начала каникул. Выделите операторы программы, необходимые для решения этой задачи.
Ваше имя (никнейм)*
Email*
Комментарий*