russstep
?>

Написать программу, которая считывает две строки, введённых пользователем. После этого программа должна вывести на экран, какая строка длиннее и на сколько символовPython)(В коде должно быть ветвление if … elif … else Вычисление разницы в длине строк должно выполняться в функции, которая принимает две строки и возвращает целое число.)

Информатика

Ответы

zybin41iz81

def get_string_length_diff(string1, string2):

   return len(string1)-len(string2)

fstring = input()

sstring = input()

strings_diff = get_string_length_diff(fstring, sstring)

print(f'первая строка длиннее на {abs(strings_diff)} символов' if (strings_diff > 0) else f'вторая строка длиннее на {abs(strings_diff)} символов')

Объяснение:

airlineskozlova69
№1

var sum, i: integer;
begin
sum := 0;
for i := 1 to 100 do
sum := sum + i;
writeln('Сумма всех чисел от 1 до 100: ', sum);
end.

№2

var p, i: integer;
begin
p := 1;
for i := 1 to 10 do p := p * i;
writeln('Произведение всех чисел от 1 до 10: ', p);
end.

№3

У вас не дано никаких условий. Вот задача для условия: "Членов прогрессии - 100, шаг - 3"

var A, i, k, max: integer;
begin
i := 3;
max := 100;
for k := 1 to max do begin
A := A + i;write( A, ' ');
end;
end.

№4

var sum, x: real;
a: array[1..10] of real;
i: integer;
begin
sum := 0;
for i := 1 to 10 do begin
write('Введите ', i, ' число: ');
readln(a[i]);
sum := sum + a[i];
end;

writeln('Сумма введенных чисел: ', sum);
end.
orgot9

static void Main(string[] args)

       {

           int N = 0;

           Console.Write("Введите размерность массива: ");

           N = Convert.ToInt32(Console.ReadLine());

           double[,] mas = new double[N, N];

           double sum = 0;

           int viborStroki = 0;

           Console.Write("Введите номер строки: ");

           viborStroki = Convert.ToInt32(Console.ReadLine());

           Random rnd = new Random();

           for(int i = 0; i < N; i++)

           {

               for(int j = 0; j<N; j++)

               {

                   mas[i, j] = rnd.Next(0, 10);

               }

           }

           for (int i = viborStroki - 1; i < viborStroki; i++)

           {

               for(int j = 0; j < N; j++)

               {

                   sum += Math.Pow(mas[i, j], 2);

               }

           }

           Console.WriteLine();

           Console.Write("Массив: ");

           Console.WriteLine();

           for (int i = 0; i < N; i++)

           {

               for (int j = 0; j < N; j++)

               {

                   Console.Write(String.Format("{0,3}", mas[i, j]));

               }

               Console.WriteLine();

           }

           Console.Write("Сумма квадратов элементов {0}-й строки = ", viborStroki);

           Console.Write("{0}", sum);

           Console.ReadKey();

       }

Объяснение:

Вводим размерность массива, вводим номер строки, программа считает сумму квадратов элементов введённой строки.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая считывает две строки, введённых пользователем. После этого программа должна вывести на экран, какая строка длиннее и на сколько символовPython)(В коде должно быть ветвление if … elif … else Вычисление разницы в длине строк должно выполняться в функции, которая принимает две строки и возвращает целое число.)
Ваше имя (никнейм)*
Email*
Комментарий*