verachus
?>

Может кто-нибудь с задачей? "3. Программа получает на вход последовательность из N целых неотрицательных чисел. Найти количество всех цифр в последовательности чисел. Ввод данных: N = 5 23 475 12 1 683" Нужно решить на Питоне и с использованием цикла while. Понятие того, что можно сделать, есть, но в голову не приходит, как это написать. Буду благодарить вас за столько, сколько хотите, но сильно нужна заранее!

Информатика

Ответы

Lopatkin_Shchepak174

N = int(input())

number_list = str(input()).split()

if len(number_list) != N:

   quit()

letter_list = []

for n in number_list:

   for i in n:

       letter_list.append(i)

amount = 0

for letter in letter_list:

   amount += int(letter)

print(letter_list)

print(amount)

забыл что нужно через while =(

sdy19576216
Если число произвольное, то оно может содержать произвольное количество цифр, большее нуля. Число считается натуральным, поэтому наложим на ввод ограничения: вводить нужно только цифры, а остальные знаки будут игнорироваться. В этом случае количество цифр в числе будет равно количеству введенных цифр. Число вводим, как символьную строку, а затем при подсчете цифр пропускаем все нецифровые символы.

const
  digits=['0','1','2','3','4','5','6','7','8','9'];
var
  s:string;
  i,k:integer;
begin
  Write('Введите произвольное натуральное число: ');
  Readln(s);
  k:=0;
  for i:=1 to Length(s) do
    if s[i] in digits then Inc(k);
  Writeln('Количество цифр в числе равно ',k)
end.

Тестовые решения:

Введите произвольное натуральное число: -43546543235.08754
Количество цифр в числе равно 16

Введите произвольное натуральное число: 96435034623
Количество цифр в числе равно 11

Введите произвольное натуральное число: И даже так: -43 323 453.657 4 посчитает!
Количество цифр в числе равно 12
igevskoemuseumkec
Если число произвольное, то оно может содержать произвольное количество цифр, большее нуля. Число считается натуральным, поэтому наложим на ввод ограничения: вводить нужно только цифры, а остальные знаки будут игнорироваться. В этом случае количество цифр в числе будет равно количеству введенных цифр. Число вводим, как символьную строку, а затем при подсчете цифр пропускаем все нецифровые символы.

const
  digits=['0','1','2','3','4','5','6','7','8','9'];
var
  s:string;
  i,k:integer;
begin
  Write('Введите произвольное натуральное число: ');
  Readln(s);
  k:=0;
  for i:=1 to Length(s) do
    if s[i] in digits then Inc(k);
  Writeln('Количество цифр в числе равно ',k)
end.

Тестовые решения:

Введите произвольное натуральное число: -43546543235.08754
Количество цифр в числе равно 16

Введите произвольное натуральное число: 96435034623
Количество цифр в числе равно 11

Введите произвольное натуральное число: И даже так: -43 323 453.657 4 посчитает!
Количество цифр в числе равно 12

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Может кто-нибудь с задачей? "3. Программа получает на вход последовательность из N целых неотрицательных чисел. Найти количество всех цифр в последовательности чисел. Ввод данных: N = 5 23 475 12 1 683" Нужно решить на Питоне и с использованием цикла while. Понятие того, что можно сделать, есть, но в голову не приходит, как это написать. Буду благодарить вас за столько, сколько хотите, но сильно нужна заранее!
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Любовь-Волков1205
Кузнецов
manuchar-formen2
Есартия52
lion13
mikhailkirakosyan
Eduardovich_Sergei1062
tihonovrv477
lsuvorova1987
kirillreznikov
denchiklo2299667
hbqhzwtd
krisrespect
mzubenko6
kazanoop