Python.. Задано список. Написати програму формування іншого списку, в якому, якщо еленти заданого списку не утворюють послідовності, яка зменшується, то замінити його від‘ємні елементи одиницями.
//PascalABC.NET //Постройте алгоритм и составьте программу, по которой будет реализован //следующий вариант сценарий: компьютер запрашивает номер дня недели, //после ввода компьютер сообщает название этого дня (типо если ввели //1 это понедельник 3 - среда)
type Arr = array [0..6] of string;
begin var DN: Arr := ('Воскресенье', 'Понедельник', 'Вторник', 'Среда', 'Четверг', 'Пятница', 'Суббота'); write('Введите порядковый номер дня недели: '); var n := ReadlnInteger; write('Этот день называется ', DN[n mod 7]) end.
evamining
06.07.2022
Если вы думаете, что величайшие изобретения обычно рождаются в воспаленном сознании одиноких гениев, подумайте еще раз. И ознакомившись с нашим списком десяти изобретений, без которых нашего мира, считай, не было бы, вдумайтесь, насколько они совершенны в своей конструкции. Обычно когда речь идет об изобретателях, в голове всплывает картинка: одинокий гений в своей тайной лаборатории, корпящий над загадочными устройствами, экспериментирующий и перебирающий идеи, пока не доведет их до ума. Так, думаем мы, рождается новое изобретение, невероятное чудо, новая технология, и становится понятно: как было уже не будет.
Отчасти, так и есть. Когда дело доходит до изобретений, без экспериментов и изменений в дизайне не обойтись. Но путь к творению, как правило, долгий и терпкий. Инженеры и любители сотни лет корпели над экзоскелетами и персональными реактивными ранцами, а их все нет и нет. И процесс включает намного больше людей, чем просто одного гения.
Читая о десяти лучших и прекраснейших изобретениях мира, становится понятно, что ничто не появляется на пустом месте. Любое творение науки и техники рождается из предыдущих наработок, которые складывались в течение десятков или сотен (или тысяч) лет. У каждого изобретения есть свои проблемы, а порой какая-нибудь штука пылится в сундуке, пока не появится другое изобретение (подумайте, например, о космическом лифте). Часто бывает, что лавры славы собирает не изобретатель, которому первому пришла в голову идея, а тот, кто создал ключевой элемент, улучшение, дополнение к изначальной конструкции.
Как и со многими изобретениями в этом списке, человек, который изобрел, по нашему мнению, печатный станок (Иоганн Гутенберг в 1430-х годах), просто улучшил уже существующие технологии и сделал их полезными и достаточно эффективными, чтобы они приобрели популярность. Мир уже пользовался бумагой и блочной печатью — китайцы дошли до этого еще в начале 11 века — но их сложный язык не дал технологии распространиться. Марко Поло привез идею в Европу в 1295 году.Холодильник — отличная штука, использующая веществ поглощать и выгружать тепло, когда меняется давление и состояние вещества (как правило, из газа в жидкость и наоборот). Сложно выделить одного изобретателя холодильника, поскольку эта идея была широко известна и постепенно улучшалась в течение почти 200 лет. Некоторые указывают на конструкцию устройства для сжатия пара, созданную Оливером Эвансом в 1805 году, другие отмечают дизайн настоящего предшественника современного холодильника вроде того, что у вас на кухне, созданный Карлом фон Линде в 1876 году. Десятки изобретателей, включая Альберта Эйнштейна, улучшали или дополняли конструкцию холодильника много лет.Может быть, нечестно объединять телеграф, радио и телевидение в одном «изобретении», но развитие коммуникационных технологий повышало полезность и эффективность сферы в целом с тех пор, как Сэмюэль Морзе изобрел электрический телеграф в 1836 году (работая над совершенно другим, разумеется). Телефон по своей сути повторил и улучшил эту идею, обеспечив людей голосовой связью по медному проводу, в отличие от сугубо текстовых сигналов, прописанных кодом Морзе. Эти методы связи работали от пункта к пункту и требовали обширной инфраструктуры проводов для функционирования.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Python.. Задано список. Написати програму формування іншого списку, в якому, якщо еленти заданого списку не утворюють послідовності, яка зменшується, то замінити його від‘ємні елементи одиницями.
//Постройте алгоритм и составьте программу, по которой будет реализован
//следующий вариант сценарий: компьютер запрашивает номер дня недели,
//после ввода компьютер сообщает название этого дня (типо если ввели
//1 это понедельник 3 - среда)
type Arr = array [0..6] of string;
begin
var DN: Arr := ('Воскресенье', 'Понедельник', 'Вторник', 'Среда',
'Четверг', 'Пятница', 'Суббота');
write('Введите порядковый номер дня недели: ');
var n := ReadlnInteger;
write('Этот день называется ', DN[n mod 7])
end.