Иванникова736
?>

Задание: Написать программу для исполнителя Чертежник, в результате которой получится рисунок, приведенный в примере ниже

Информатика

Ответы

Мельникова

Решение

Объяснение:

1. Создать 2 переменные, сделать проверку через if Если a>b то writeln(a+b) else writeln(a*b) После этого writeln("ЗАДАЧА РЕШЕНА")

2.Создать переменную n(Сколько лет дракону) и h(Голова) Так же сделать проверку через if сколько ему лет Если >100 то n*3 Если <100 То (100*3)+((n-100)*2) и записать в переменную h

Что бы получить глаза достаточно h*2 (если у дракона 2 глаза)

3.Создать 2 переменные, сделать проверку через if допустим если a<b writeln(a) else (b)

4.Создать переменную в которую пользователь будет вводить число,

После этого надо его делить на 4 и округлять в меньшую сторону

Если число будет 1 - Зима Если 2 - Весна 3 - Лето 4-Зима

5. -

6. Создаем 2 переменные a,b - Записываем в них длины сторон после умножаем a*b

7.Создаем переменную скорости и расстояния - Потом Расстояние делим на скорость 600/120 И получаем время в полете

8.-

rykovatv6
{1}

const
 s:string = 'IVXLCDM';
var
 x,i,l,k:integer;

begin
 read(x); {x < 4000}
 l := 1000;
 i := 4;
 for i := 4 downto 1 do
   begin
   k := x div l mod 10;
   if k = 9 then
     write(s[i*2-1],s[i*2+1])
   else
   if k = 4 then
     write(s[i*2-1],s[i*2])
   else
     begin
     if k >= 5 then
       begin
       write(s[i*2]);
       k := k - 5
       end;
     for k := k downto 1 do
       write(s[i*2-1])
     end;
   l := l div 10
   end
end.

{2}

const
 eps = 1e-10;
 stp = 500;

var
 a: real;
 l,r,m: real;
 extreme: real;

function f(x:real):real;
begin
 f := a*x - exp(-x)
end;

begin
 read(a);
 if a = 0 then
   writeln('No solutions')
 else
 if a > 0 then
   begin
   l := 0;
   r := stp*2;
   while f(r) <= 0 do
     begin
     l := l + stp;
     r := r + stp
     end;
   while r - l > eps do
     begin
     m := (l + r)/2;
     if f(m) > 0 then
       r := m
     else
       l := m
     end;
   m := (l + r) / 2;
   writeln('Solution: ',m:0:5);
   writeln('e^-x = ',exp(-m):0:5);
   writeln('ax = ',a*m:0:5)
   end
 else
   begin
   extreme := ln(-1/a);
   if f(extreme) < 0 then
     writeln('No solutions')
   else
   if f(extreme) = 0 then
     writeln('Solution: ',extreme)
   else
     begin
     {writeln('Extreme: ',extreme);}
          l := extreme;
     r := 0;
     while r - l > eps do
       begin
       m := (l + r)/2;
       if f(m) < 0 then
         r := m
       else
         l := m
       end;
     m := (l + r) / 2;
     writeln('Solution 1: ',m:0:5);
     writeln('e^-x = ',exp(-m):0:5);
     writeln('ax = ',a*m:0:5);
     writeln;
          r := extreme;
     l := r - stp*2;
     while f(l) > 0 do
       begin
       l := l - stp;
       r := r - stp
       end;
     while r - l > eps do
       begin
       m := (l + r)/2;
       if f(m) > 0 then
         r := m
       else
         l := m
       end;
     m := (l + r) / 2;
     writeln('Solution 2: ',m:0:5);
     writeln('e^-x = ',exp(-m):0:5);
     writeln('ax = ',a*m:0:5)
           end
   end
end.

{3}

var
 c: array [1..12] of 0..7;
 x,i,k: integer;

begin
 read(x);
 k := x;
 i := 0;
 repeat
   i := i + 1;
   c[i] := k mod 8;
   k := k div 8
 until k = 0;
 for i := i downto 1 do
   write(c[i])
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задание: Написать программу для исполнителя Чертежник, в результате которой получится рисунок, приведенный в примере ниже
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

лукашова940
udalova-yelena
Aleks0091
Салиев
eobmankina
milenaochirova01017424
skorykin123371
yurazharov
Igorevich1559
olgakuz00261
gennadevna
maksimforyou20
flerbuket332
svetasvetlana429
elmira070485