Поделитесь своими знаниями, ответьте на вопрос:
Составить программу в Паскале для обработки массива из 10 чисел Х = (–17, 3; 13, 2; –7; –2, 36; 123, 4; –0, 3; 12, 356; 142; 0; –1 Вычислить количество элементов массива с нечетными номерами на отрезке [5, 1..32, 4]. В отчет включить программный код и результат работы программы.
var A: array[1..10] of real =
(-17.3, 13.2, -7, -2.36, 123.4, -0.3, 12.356, 142, 0, -1);
var i,cnt: integer;
begin
cnt:=0;
for i:=1 to 10 do
begin
if ((A[i]>=5.1) and (A[i]<=32.4) and (i mod 2 <> 0))
then cnt:=cnt+1;
end;
writeln('Количество элементов массива с нечетными номерами',
'на отрезке [5,1..32,4]: ', cnt);
end.