os2854
?>

Написать программу на языке Паскаль для вычисления значения выражения z=(x-y/2)+(x/6)

Информатика

Ответы

anton1969026203

begin

var x, y, z: real;

Write('Введите значение x= ');

Read(x);

Write('Введите значение y= ');

Read(y);

z := (x - y / 2) + (x / 6);

Writeln('z= ', z);

end.

oniks-plus
Вивести на екран вікно з повідомленням можна за до процедури ShowMessage або функції MessageDlg.

Процедура ShowMessage виводить на екран вікно з текстом і командної кнопкою ОК.
У загальному вигляді інструкція виклику процедури ShowMessage виглядає так:
ShowMessage (Повідомлення);
де повідомлення – текст, який буде виведений у вікні.

Слід звернути увагу на те, що в заголовку вікна повідомлення, що виводиться процедурою ShowMessage, зазначено назва програми, з якою задається на вкладці Application вікна Project Options. Якщо назва додатка не задано, то в заголовку буде ім’я виконуваного файлу.
Дементьева-Артем1315

===== PascalABC.NET =====

= 1 =

begin

 var n := ReadInteger('N =');

 var A := ArrRandom(n, -99, 99);

 A.Println;

 // собственно, решение

 var s := A.Sum; // сумма всех элементов массива

 var L := new List<integer>; // то, что войдет в массив В

 // берем каждого претендента и сравниваем его с остальной суммой

 for var i := 0 to A.High do

   if (Abs(A[i] mod 10) = 5) and (A[i] > s - A[i]) then

     L.Add(A[i]);

 var B := L.ToArray;

 if B.Length > 0 then

 begin

   Print('Особые элементы:');

   B.Print

 end  

 else

   Print('Нет "особых" элементов');

end.

= 2 =

begin

 var n := ReadInteger('N =');

 var A := ArrRandom(n, -10, 10);

 A.Println;

 // собственно, решение

 var D := new Dictionary<integer, integer>; // словарь

 foreach var k in A do // перебор элементов

   if D.ContainsKey(k) then

     D[k] += 1 // +1, если такой элемент был

   else

     D.Add(k, 1); // 1, если элемент встретился впервые

 D.Count(p -> p.Value > 1).Print

end.


1.Дан одномерный целочисленный массив А, состоящий из N элементов, N - заданное натуральное число. Э
1.Дан одномерный целочисленный массив А, состоящий из N элементов, N - заданное натуральное число. Э

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке Паскаль для вычисления значения выражения z=(x-y/2)+(x/6)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Иванова
AleksandrovnaIgor
Dmitrievich-Telishev
hbqhzwtd
ГармаеваЕкатерина1637
m-illarionov
Елена_Кошевой
inbox466
vainshakov
MaratФам
NikonA83
filimon131262
vetrov1
Оксана Николаевич
petrowich076813