marinazubcko16729
?>

Нужно написать программу и составить блок-схему: Даны три целочисленных массива A, B и C размера N(A), N(B), N(C) соответственно, элементы которых упорядочены по убыванию. Объединить эти массивы так, чтобы результирующий целочисленный массив D (размера N(A) + N(B) + N(C)) остался упорядоченным по убыванию.

Информатика

Ответы

mikchaylovaalex

#Python

d = a + b + c

d.sort()# сортировка по возростанию

d = d[::-1]# разворачивание

КириллЕгорова1906
Код Pascal;

Var
   x,y,v,h,dx:real;
Begin
Write('y = ');ReadLn(y);
Write('v = ');ReadLn(v);
Write('h = ');ReadLn(h);
dx:=0.31;
x:=-4;
Repeat
WriteLn('f(',x,') = ',Exp(Sin(y)*Abs(x))-3*Sqrt(v-h));
x:=x+dx;
Until x > -1
End.

Пример работы программы:

y = 3
v = 4
h = 2
f(-4) = -2.4841075227142
f(-3.69) = -2.55937994576573
f(-3.38) = -2.63143040076643
f(-3.07) = -2.70039680114727
f(-2.76) = -2.76641115707942
f(-2.45) = -2.82959982815798
f(-2.14) = -2.89008376526975
f(-1.83) = -2.94797874210812
f(-1.52) = -3.00339557677815
f(-1.21) = -3.05644034391605
bulin2001

Массив - структура данных, которая хранит однотипные данные, это их главное отличие от списков, так как списки могут хранить в себе разные типы данных.

Все мы ходим в магазины, примерами однотипных данных могут быть ценники (именно цена), само количество продуктов, дата производства.

Служебное слово print() выводит объекты на стандартное устройства вывода, ну короче говоря, на экран выводит какой-либо текст/переменные.

Типов данных много: Числа, списки, кортежи, множества, строки, словари, байты, логический тип, также есть тип NoneType.

В Python можно проводить все операции над числами: деление, умножение, вычитание, сложение с предназначенных для этого символов.

+ - сложение

- - вычитание

* - умножение

/ - деление

// - целочисленное деление

% - деление с остатком

** - возведение в степень

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно написать программу и составить блок-схему: Даны три целочисленных массива A, B и C размера N(A), N(B), N(C) соответственно, элементы которых упорядочены по убыванию. Объединить эти массивы так, чтобы результирующий целочисленный массив D (размера N(A) + N(B) + N(C)) остался упорядоченным по убыванию.
Ваше имя (никнейм)*
Email*
Комментарий*