Ивлев1508
?>

Даны три вещественных числа a, b, c. Определить, имеется ли среди них хотя бы одна пара равных между собой чисел. Написать программу на языке Python

Информатика

Ответы

ksv89

number_list = [float(input()) for n in range(3)]

if number_list[0] == number_list[1] or \

number_list[0] == number_list[2] or \

number_list[1] == number_list[2] or \

number_list[0] == number_list[1] == number_list[2]:

   print('имеется . ')

else:

   print('равных между собой чисел нет .')

coffee2201

Видеоурок 

Текстовый урок 

Тесты

Во к уроку

На предыдущих уроках мы подробно рассмотрели внутреннее устройство компьютера – его комплектующие и основные внутренние части. Однако для того, чтобы рассматривать современный компьютер как полноценное средство обработки информации (то есть устройство, выполняющее конкретные прикладные задачи), необходимо учесть также и его программное обеспечение, то есть все приложения и службы, установленные на данный компьютер. На сегодняшнем уроке вы познакомитесь с различными видами программного обеспечения, узнаете, для чего нужна та или иная программа и научитесь их устанавливать.

Введение

Что же такое программное обеспечение компьютера? Рассмотрим этот термин подробнее.

Программное обеспечение (ПО) – это все компьютерные программы, процедуры и соответствующая документация и данные, относящиеся к функционированию данной компьютерной системы.

Всё программное обеспечение можно разделить на следующие типы

Виды программного обеспечения

1. Системное программное обеспечение. Это такие программы, которые входят в состав операционной системы и являются составной ее частью. Обычно они обеспечивают управление компонентами компьютерной системы, такими как процессор, оперативная память, устройства ввода-вывода а также сетевое оборудование. Типичным примером для системной программы является драйвер. Драйвер– это компьютерная программа, при которой другие программы получают доступ к аппаратному обеспечению некоторого устройства (например, к принтеру, сканеру, видеокарте и т. д.). Драйверы являются неотъемлемой составляющей операционной системы – совокупность программ, организующих согласованную работу всех модулей компьютера.

2. Обслуживающие программы.К ним относятся те программы, которые выполняют вс обслуживающие либо сервисные функции, например архиваторы, антивирусы и программы для обслуживания жесткого диска компьютера. Программы такого типа также называют утилитами (от англ. utilize – «использовать»).

3. Прикладные программы –это обширный класс программ, предназначенный для решения отдельных определенных пользователем задач, связанных с обработкой данных в определенной области деятельности. К ним можно отнести, например, текстовые, графические, аудио, видео-редакторы, средства управления базами данных, обучающие, тестовые, игровые программы и т. д.

Большинство программ на сегодняшний день создаются с привязкой к конкретной операционной системе (например, Windows, Linux, Android, MacOS) и т. д. Этот факт необходимо обязательно учитывать при выборе той или иной программы.

Перед запуском программы ее нужно правильным образом инсталлировать, то есть установить на данный компьютер. Существуют специальные программы-инсталляторы, например Rpm для ОС Linux или Windows Installer для Windows. Очень часто программы-инсталляторы входят в состав операционной системы по умолчанию. Инсталлировать программу – означает установить (распаковать) все ее значимые файлы в соответствующие директории операционной системы. Для того чтобы программа инсталлировалась верно, она должна содержать так называемый дистрибутив. Дистрибутив программы (от англ. distribute – распределять) – это совокупность компонентов, необходимых для ее установки (инсталляции). Дистрибутив операционной системы обычно содержит в себе программы для начальной инициализации системы.

yna21289

Объяснение:

program treugolnik;

uses crt;

var

x1, y1, x2, y2, x3, y3, p:real;

function dlina(a1,b1, a2,b2:real):real;

begin

dlina:=sqrt(sqr(a1-a2)+sqr(b1-b2));

end;

begin

writeln('Введите координаты 1-ой вершины');

write('x='); readln(x1);

write('y='); readln(y1);

writeln('Введите координаты 2-ой вершины');

write('x='); readln(x2);

write('y='); readln(y2);

writeln('Введите координаты 3-ей вершины');

write('x='); readln(x3);

write('y='); readln(y3);

p:=dlina(x1,y1,x2,y2)+dlina(x1,y1,x3,y3)+dlina(x2,y2,x3,y3);

writeln('Периметр=',p);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны три вещественных числа a, b, c. Определить, имеется ли среди них хотя бы одна пара равных между собой чисел. Написать программу на языке Python
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

dddandmvd5210
Lenok33lenok89
Ter-Pogosov_Vasilevna
muz-cd
eizmaylova6
kuchino09
Дубровская571
yakovlevasvetlanalvovna209
olartamonov6
yurazharov
anastasiaevent4
Columbia777
eleniloy26
лукашова940
officem695