Дмитрий Бундин
?>

Составить программу, которая сортирует четыре числа по порядку убывания /используя массивы/. Желательно несколько вариантов программы

Информатика

Ответы

anatolevich1931

def print_digit_sum(a):

 print(f'Сумма цифр числа {a} равна {sum([int(i) for i in str(a)])}')

while True:

 try:

   print_digit_sum(int(input('Введите целое число:')))

   break

 except ValueError:

   print('Неверный формат входных данных')

sum([int(i) for i in str(a)]) - здесь мы выполняем следующие действия:

1. Преобразуем число в строку с str(a)

2. Пробегаемся по символам строки от первого до последнего и создаём массив, преобразуя каждый строковый символ в число - [int(i) for i in str(a)]

3. Ну и наконец с оператора sum вычисляем сумму всех элементов получившегося массива

ostapbender1111

Это программы общего пользования не связаны с конкретным применением ПК и выполняют традиционные функции: планирование и управление задачами, управления вводом-выводом и т. д.  

 

Другими словами, системные программы выполняют различные вс функции, например, создание копий используемой информации, выдачу справочной информации о компьютере, проверку работо устройств компьютера и т. п.  

 

К системному ПО относятся:  

# операционные системы (эта программа загружается в ОЗУ при включении компьютера)  

# программы – оболочки (обеспечивают более удобный и наглядный общения с компьютером, чем с командной строки DOS, например, Norton Commander)  

# операционные оболочки – интерфейсные системы, которые используются для создания графических интерфейсов, мультипрограммирования и. т.  

# Драйверы (программы, предназначенные для управления портами периферийных устройств, обычно загружаются в оперативную память при запуске компьютера)  

# утилиты (вс или служебные программы, которые представляют пользователю ряд дополнительных услуг)  

К утилитам относятся:  

# диспетчеры файлов или файловые менеджеры  

# средства динамического сжатия данных (позволяют увеличить количество информации на диске за счет ее динамического сжатия)  

# средства просмотра и воспроизведения  

# средства диагностики; средства контроля позволяют проверить конфигурацию компьютера и проверить работо устройств компьютера, прежде всего жестких дисков  

# средства коммуникаций (коммуникационные программы) предназначены для организации обмена информацией между компьютерами  

# средства обеспечения компьютерной безопасности (резервное копирование, антивирусное ПО) .  

 

Необходимо отметить, что часть утилит входит в состав операционной системы, а другая часть функционирует автономно. Большая часть общего (системного) ПО входит в состав ОС. Часть общего ПО входит в состав самого компьютера (часть программ ОС и контролирующих тестов записана в ПЗУ или ППЗУ, установленных на системной плате) . Часть общего ПО относится к автономными программам и поставляется отдельно.  

 

Прикладное ПО  

Прикладные программы могут использоваться автономно или в составе программных комплексов или пакетов. Прикладное ПО – программы, непосредственно обеспечивающие выполнение необходимых работ на ПК: редактирование текстовых документов, создание рисунков или картинок, создание электронных таблиц и т. д.  

 

Пакеты прикладных программ – это система программ, которые по сфере применения делятся на проблемно – ориентированные, пакеты общего назначения и интегрированные пакеты. Современные интегрированные пакеты содержат до пяти функциональных компонентов: тестовый и табличный процессор, СУБД, графический редактор, телекоммуникационные средства.  

 

К прикладному ПО, например, относятся:  

# Комплект офисных приложений MS OFFICE  

# Бухгалтерские системы  

# Финансовые аналитические системы  

# Интегрированные пакеты делопроизводства  

# CAD – системы (системы автоматизированного проектирования)  

# Редакторы HTML или Web – редакторы  

# Браузеры – средства просмотра Web - страниц  

# Графические редакторы  

# Экспертные системы  

И так далее

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая сортирует четыре числа по порядку убывания /используя массивы/. Желательно несколько вариантов программы
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Serkova_Elena251
abuley
fednik3337923
o-kate17
Максим
menesmir
maximovpavel9114
parolmm
Pogosyan Nataliya
Терентьева
kartyshkinaaa
leeka152522
БеляковаСтаниславовна
Prostofil200790
skononova01