voloshin238
?>

На языке паскаль написать программу которая вычисляет данную функцию: b = y в степени(x) + корень кубический из ( |x| + |y| Где х = -0.85, а у= 1.25.

Информатика

Ответы

stailwomen31
// PascalABC.Net 3.0, сборка 1052
const
  Rus=['А'..'Я'];
var
  s:string;
  i,k,t:integer;
  c,c1,tc,sc:char;
  f:array['А'..'а'] of byte; // 'а' - это для 'Ё'
  ch:array['А'..'а'] of char;
begin
  Write('Введите строку: '); Readln(s);
  for c:='А' to 'а' do begin f[c]:=0; ch[c]:=c end;
  k:=0;
  for i:=1 to Length(s) do begin
    c:=UpCase(s[i]);
    if c in Rus then begin Inc(f[c]); Inc(k) end
    else
      if c='Ё' then begin Inc(f['а']); Inc(k) end;
  end;
  Writeln('Количество русских букв равно ',k);
  { сортировка массива со счетчиком количества букв }
  for c1:='А' to Pred('а') do
  for c:='А' to Pred('а') do
    if f[c]<f[Succ(c)] then begin
      t:=f[c]; tc:=ch[c]; sc:=Succ(c);
      f[c]:=f[sc]; ch[c]:=ch[sc];
      f[sc]:=t; ch[sc]:=tc
    end;
  Writeln('Частота встретившихся букв');
  c:='А';
  while (c<='а') and (f[c]>0) do begin
    if ch[c]='а' then ch[c]:='Ё';
    Writeln(ch[c],' - ',f[c]);
    Inc(c)
  end;
end.

Тестовое решение:
Введите строку: Когда я был парнишкой, носил я брюки клёш
Количество русских букв равно 33
Частота встретившихся букв
К - 4
И - 3
Л - 3
О - 3
А - 2
Б - 2
Н - 2
Р - 2
Ш - 2
Я - 2
Г - 1
Д - 1
Й - 1
П - 1
С - 1
Ы - 1
Ю - 1
Ё - 1
Иванов1813
'VBScript

Sub Zadanie()
    ReDim C(5, 6)

    k_pos = 0
    mini = LBound(C, 1)
    minj = LBound(C, 2)
    For i = LBound(C, 1) To UBound(C, 1)
        For j = LBound(C, 2) To UBound(C, 2)
            C(i, j) = Round(Rnd * 10)

            if C(i, j) > 0 then k_pos = k_pos + 1

            if C(i, j) < C(mini, minj) then
                mini = i
                minj = j
            end if
        Next
    Next

    MsgBox "min C(" & mini & ", " & minj & ")=" & C(mini, minj) & vbNewLine & "c>0: " & k_pos
End Sub

Call Zadanie()

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На языке паскаль написать программу которая вычисляет данную функцию: b = y в степени(x) + корень кубический из ( |x| + |y| Где х = -0.85, а у= 1.25.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Larax0819
Валерия Воробьева396
abadaeva
Rakitin
Николаевна
Поликарпова-Мазурова
serge-lysoff
Геннадьевна Вета560
andrewa
tsatskina857
xeniagolovitinskaya4546
rastockin8410
elenabarskova7145
premiumoft
macmakka
▲