sevro3038
?>

Написать программу, которая вводит массив из K случайных целых чисел в диапазоне от -500 до 100 и выводит на экран элементы, кратные числу N(вводим с

Информатика

Ответы

annanas08

На будущее: конкретнее объясняй откуда берутся числа(например ввод через input или конкретные значения)

Если что, то что после # это комментарий и его можно убрать

def count(a, p):

   return (p-a)/2 #периметр это сумма сторон. Отнимем A и получим сумму двух сторон. Т.к. они одинаковые, при делении на 2 получим длину одной из двух сторон

# я для примера возьму числа у пользователя через input

a = int(input('Введи A: '))

p = int(input('Введи периметр: '))

x = count(a, p)

print(f'Одна сторона: {x}. Две одинаковых стороны вместе: {x*2}')

Объяснение:

код работает

magazin7452834

На будущее: конкретнее объясняй откуда берутся числа(например ввод через input или конкретные значения)

Если что, то что после # это комментарий и его можно убрать

def count(a, p):

   return (p-a)/2 #периметр это сумма сторон. Отнимем A и получим сумму двух сторон. Т.к. они одинаковые, при делении на 2 получим длину одной из двух сторон

# я для примера возьму числа у пользователя через input

a = int(input('Введи A: '))

p = int(input('Введи периметр: '))

x = count(a, p)

print(f'Одна сторона: {x}. Две одинаковых стороны вместе: {x*2}')

Объяснение:

код работает

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая вводит массив из K случайных целых чисел в диапазоне от -500 до 100 и выводит на экран элементы, кратные числу N(вводим с
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

char40
tkmandarin8376
Алёна Геннадьевна98
stasyan
Виталий_Ильназ574
Anna-Miron
Сергей
Chopper-hinter25
delo1005
vova00831
venera2611
смирнов1127
Olegovna Volkov
ruslan
▲