agusarevich283
?>

Заполнение диагоналями По данным числам n и m заполните двумерный массив размером n∗m числами от 1 до n∗m “диагоналями”, как показано в примере. Входные данные Вводятся два числа n и m. Выходные данные Выведите полученный массив, отводя на вывод каждого элемента ровно 4 символа. В языке Python для этого можно использовать метод rjust (выравнивание по правому краю с указанием числа позиций для вывода Например, так: Примеры Ввод Вывод 3 5 1 2 4 7 10 3 5 8 11 13 6 9 12 14 15 Решите задачу на

Информатика

Ответы

Вишняков997

#include <iostream>

int main(void){

   const int N = 3;

   const int M = 5;

   int mat[N][M];

   int i, j, row = 0, col = 0, n = 1;

   while(row <= (N - 1)){

       i = row;

       j = col;

       while((i < N) && (j >= 0))

           mat[i++][j--] = n++;    

       if(col < (M - 1))

           ++col;

       else

           ++row;

   }

   for(i = 0; i < N; ++i){

       for(j = 0; j < M; ++j){

           std::cout.width(3);

           std::cout << mat[i][j];

       }

       std::cout << std::endl;

   }

   return 0;

}

Объяснение:

ajsklan

1.

монитор , мышь , клавиатура , и системный блок

2.

Системный блок — это элемент персонального компьютера, который защищает компоненты компьютера

Периферийные устройства – это любые дополнительные и вс устройства, которые подключаются к ПК для расширения его функциональных возможностей

Устройства ввода — периферийное оборудование, предназначенное для ввода данных или сигналов в компьютер или в другое электронное устройство во время его работы.  

Плоттер — устройство для автоматического вычерчивания с большой точностью рисунков, схем, сложных чертежей, карт и другой графической информации на бумаге размером до A0 или кальке.

Кэш микропроцессора — кэш (сверхоперативная память), используемый микропроцессором компьютера для уменьшения среднего времени доступа к компьютерной памяти. Является одним из верхних уровней иерархии памяти.

3.

Диск С – 7 класс – домашнее задание – графика – рыбка.png

4.

Операционная система Сервисные программы Инструментальные программы Программы технического обслуживания компьютера

Объяснение:

osechkinandrejj

1.

монитор , мышь , клавиатура , и системный блок

2.

Системный блок — это элемент персонального компьютера, который защищает компоненты компьютера

Периферийные устройства – это любые дополнительные и вс устройства, которые подключаются к ПК для расширения его функциональных возможностей

Устройства ввода — периферийное оборудование, предназначенное для ввода данных или сигналов в компьютер или в другое электронное устройство во время его работы.  

Плоттер — устройство для автоматического вычерчивания с большой точностью рисунков, схем, сложных чертежей, карт и другой графической информации на бумаге размером до A0 или кальке.

Кэш микропроцессора — кэш (сверхоперативная память), используемый микропроцессором компьютера для уменьшения среднего времени доступа к компьютерной памяти. Является одним из верхних уровней иерархии памяти.

3.

Диск С – 7 класс – домашнее задание – графика – рыбка.png

4.

Операционная система Сервисные программы Инструментальные программы Программы технического обслуживания компьютера

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Заполнение диагоналями По данным числам n и m заполните двумерный массив размером n∗m числами от 1 до n∗m “диагоналями”, как показано в примере. Входные данные Вводятся два числа n и m. Выходные данные Выведите полученный массив, отводя на вывод каждого элемента ровно 4 символа. В языке Python для этого можно использовать метод rjust (выравнивание по правому краю с указанием числа позиций для вывода Например, так: Примеры Ввод Вывод 3 5 1 2 4 7 10 3 5 8 11 13 6 9 12 14 15 Решите задачу на
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

gurman171
ivan-levermor
skrepka397412
Tkachenko1050
Владимировна Екатерина
lovel24
gilmore886173
Tkachenko1050
ritckshulga20112
s45983765471717
Itina321t
anaissite6
Irinalobanowa
perovd8111
mulyugina365