mb9037479491
?>

ВЫПОЛНИТЕ Напишите программу, которая считывает с клавиатуры n чисел и затем выводит на экран: а)сумму и среднее арифметическое считанных чил; б)сумму и среднее арифметическое положительных чисел; в)сумму и среднее арифметическое отрицательных чисел.

Информатика

Ответы

symkifm

PascalABC.NET 3.5.1 + .NET Framework 4.7.1

begin

 var A := ReadArrInteger(readinteger('n = '));

 //Среднее арифметическое

 A.Average.Println;

 //Среднее арифметическое положительных

 A.Where(p -> p >= 0).Average.Println;

 //Среднее арифметическое отрицательных

 A.Where(p -> p < 0).Average.Println;

end.

Объяснение:

Сергеевна-С.А.1549

1.3апустить на выполнение файл «WlnAVR-20100110-install.exe» (29 Мбайт), находящийся на прилагаемом компакт-диске. Этот файл при необходимости можно свободно скачать из Интернета . Инсталлировать WlnAVR по умолчанию в папку C:\WinAVR-20100110\.

2. Открыть редактор PN2: «Пуск - Программы - WinAVR-20100110 - Programmers Notepad ». Включить нумерацию строк: «Tools - Options - General - Default - <поставить «галочку» возле «Show Line Numbers»> - ОК».

3. Создать в редакторе PN2 новый Си-файл: «File - New - С/С++». Ввести с клавиатуры текст программы  и сохранить его на жёстком диске: «File - Save As… - <ввести путь и имя файла, например, для однозначности C:\1001\demol.c> - ОК».

Здесь и далее снимки экранов (скриншоты) для экономии места будут показываться только в самых важных точках действий. Остальные скриншоты в пошаговом режиме можно посмотреть на видеоуроках в прилагаемом компакт-диске.

Пояснения к листингу.

Строка 1 начинается с комментариев, которые ограничиваются слева двумя наклонными линиями «прямой слеш». Весь текст после знаков «//» может быть о чём угодно, на любом языке, с любыми вольностями и сокращениями. Это произвольная информация, которую программист пишет для самого себя, любимого, чтобы через месяц-другой вспомнить, о чём, собственно, шла речь. Обычно указывается краткое название программы и авторство.

Строка 2 тоже содержит комментарии, но уже технического плана. Здесь расписана электрическая схема подключения индикатора HL1 и кнопки SB1 к конкретным линиям портов MK. Названия сигналов соответствуют раскладке из дашита на MHKpocxeMyATmega48A

vtarasyuk

var

 n,k:integer;

 a:array of integer;

 s,k2:real;

begin

 

 {Ввод размера массива и элементов массива}

 while n<3 do begin

   write('Введите размер массива - '); readln(n);

   if n<3 then writeln('[Массив слишком короткий]');

 end;

 setLength(a,n);

 for var i1:=0 to n-1 do begin

   write('Введите ',i1+1,' элемент массива - '); readln(a[i1]);

 end;

 

 {Вычесление минимальной суммы трёх соседних элементов массива}

 s:=a[0]+a[1]+a[2];

 for var i2:=2 to n-2 do begin

   k:=a[i2-1]+a[i2]+a[i2+1];

   if s>k then s:=k;

 end;

 writeln('Минимальная сумма трёх соседних элементов = ',s);

 

 {Выполнение условия чётности и нечётности}

 k2:=s;

 while k2>=2 do begin

   k2:=k2-2;

 end;

 if k2=0 then s:=sqr(s)

 else s:=sqrt(s);

 write('ответ: ',s:0:3);

 

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

ВЫПОЛНИТЕ Напишите программу, которая считывает с клавиатуры n чисел и затем выводит на экран: а)сумму и среднее арифметическое считанных чил; б)сумму и среднее арифметическое положительных чисел; в)сумму и среднее арифметическое отрицательных чисел.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

AOS2015
armsam76
turovvlad
ukkavtodor6
Михеев557
M10M11M12
Панков1101
Coffee3862
elmira01048775
martinzdraste
николаевич-Елена988
Berezovskaya
borisov
frolevgevg6420
kolgatin69