Shcherbakov_Artur1781
?>

Сгенерировать и вывести массив случайных чисел, состоящий из 16 элементов, заполненный случайными числами от 12 до 25?

Информатика

Ответы

Olybetezina1973

var a:^array[1..100] of integer;

   n,i,j:integer;

begin

new(a);

repeat

write('Введите размер массива от 12 до 25 n=');

readln(n);

until n in [12..125];

for i:=1 to n do

begin

 a^[i]:=1+random(100);

 write(a^[i]:4);

end

end.

Объяснение:

inessa12006
Число DCXLI, записанное римскими цифрами, в десятичной системе счисления соответствует числу:
D = 500, С = 100, XL = L - X = 50 - 10 = 40, I = 1
DCXLI = 500 + 100 + 40 + 1 = 641
 
Выберите те числа, в которых есть ошибка:
1902,25 (8) — ошибка, в восьмеричной системе нет цифры 9
12,21 (3) — ок
A6,4 (12) — ок, A = 10
99,99 (9) — ошибка, в девятеричной системе нет цифры 9
 
Алфавит восьмеричной системы счисления записывается так:
{0,1,2,…,7} — для n-ичной системы счисления это цифры от 0 до n - 1.
 
Последовательность знаков числа 11011 (2) в десятичной системе счисления соответствует числу: 
2^4 + 2^3 + 2^1 + 2^0 = 16 + 8 + 2 + 1 = 27 (10)
 
Переведите число 207 (8) в десятичную систему счисления.
207 (8) = 2 * 8^2 + 0 * 8^1 + 7 * 8^0 = 128 + 0 + 7 = 135 (10)
 
Переведите число 18 (10) в двоичную систему счисления.
18 (10) = 16 + 2 = 1 * 2^4 + 0 * 2^3 + 0 * 2^2 + 1 * 2^1 + 0 * 2^0 = 10010 (2)
 
Переведите число 75 (10) в шестнадцатеричную систему счисления.
75 (10) = 4 * 16 + 11 = 4B (16)
 
Греются на солнышке воробьи. На нижней ветке их было 110 (2), на верхней – на 2 (10) меньше. Сколько всего было воробьев?
110 (2) = 2^2 + 2^1 = 5 — на первой ветке
5 - 2 = 3 — на второй ветке
5 + 3 = 8 — всего
 
Укажите основание х системы счисления, если известно, что 29 (10) = 38 (х).
38 (x) = 3 * x + 8 = 29 (10)
3x + 8 = 29
3x = 21
x = 7
Marina658
1. Язык программирования Pascal создал:
a. Н. Вирт

2. Линейная структура построения программы подразумевает
b. Последовательное выполнение всех элементов программы

3. Оператор присваивания имеет вид:
b. :=

4. Команда CLRSCR служит для
c. очистки экрана

5. раздел VAR служит
a. Для описания используемых переменных

6. Переменные – это:
a. величины, которые могут менять свое значение в процессе выполнения программы

7. Правильная строковая запись выражения
b. x-x*x*x/abs (x) +sin (x)
Так как скобки там не на что не влияют, то их отсутствие правильный вариант в отличае от пункта с
Пункт а тоже может быть верным в языке где степень определена как ***, например в Ruby это **. Без указания языка/универсальным будет ответ b

8. целочисленное деление можно выразить следующей функцией:
b. A div B

9. математическое выражение х2-7х+6 можно записать:
x*x-7*x+6

10. выражение на паскале (abs (x)-abs(y))/(1 + abs (1/s)) можно записать:
 (|x|-|y|)/(1+|1/s|)

11. раздел операторов начинается служебным словом:
c. BEGIN

12. ввод данных с клавиатуры осуществляется с оператора:
b. READ, READLN

13. вывод данных на экран осуществляется с оператора:
a. WRITE, WRITELN

14. чему будет равно значение переменной М в результате выполнения серии операторов
N:=5;
Y:=2;
M:=N/5+3*Y*N
M = 1+3*2*5=31

15. тип переменных REAL это:
d. верного ответа нет

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Сгенерировать и вывести массив случайных чисел, состоящий из 16 элементов, заполненный случайными числами от 12 до 25?
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

lena260980
НосовЖелиховская
marychev55
Жуков219
dyatchina63
patersimon1
kv135549
emartynova25
ЕкатеринаРустам
vkorz594
olofinskayae
zmlavra
zazaza74
Alyona
JisesLove19955