nikdenly
?>

Придумайте задачу, для решения которой необходимо использовать оператор выбора, составьте программу для её решения.

Информатика

Ответы

memmedovallahverdi0239
// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
function SHarm(m:integer):real:=Range(1,m).Select(x->1/x).Sum;

begin
  var a:=ReadReal('a=');
  var m:=1;
  while SHarm(m)<=a do Inc(m);
  Writeln('m=',m)
end.

Тестовое решение:
a= 5
m=83

Указанный ряд - это известный в математике расходящийся гармонический ряд. Его приближенное значение суммы можно определить по формуле Эйлера:
\displaystyle S(m)=\sum_{i=1}^m \frac{1}{i} \approx \ln(m)+C, \quad C\approx 0.577\ 215\ 664\ 902
Нам требуется определить m, для которого S(m)>a, тогда
\displayvalue \ln(m)+C\ \textgreater \ a; \ ln(m)\ \textgreater \ a-C \to m\ \textgreater \ e^{a-C}
Будем искать m, отбрасывая дробную часть полученного результата, а потом делать уточнение путем непосредственного вычисления сумм.

// PascalABC.NET 3.0, сборка 1160 от 05.02.2016

const C=0.577215664902; // Постоянная Эйлера-Маскерони

function SHarm(m:integer):real:=Range(1,m).Select(x->1/x).Sum;

begin
  var a:=ReadReal('a=');
  var m:=1;
  if a<=3 then begin
    while SHarm(m)<=a do Inc(m);
    Writeln('m=',m)
    end
  else begin
    var s:real:=Int(exp(a-C));
    if a<10 then begin
      m:=Trunc(s);
      while SHarm(m)<=a do Inc(m);
      Writeln('m=',m)
      end
    else Writeln('m=',s)
    end
end.

В этом случае можно проводить оценочный расчет для больших значений а:

a= 200
m=4.05709150011779E+86
peshnoshamon
Программа векторной графики CorelDRAW 12 вместе с программой растровой графики Corel PHOTO-PAINT 12 и несколькими дополнительными программами составляет пакет графических программ CorelDRAW Graphic Suite 12, разработанный известной фирмой-производителем графических программных продуктов Corel Corporation. CorelDRAW 12 предназначена для разработки макетов документов, в которых преобладает графическая информация, с целью их публикации в качестве типографской продукции и в электронном виде. 
Программы, позволяющие обрабатывать векторные объекты наряду с растровыми изображениями и текстовой информацией, обычно называются программами векторной графики. Это название можно отнести и к программе CorelDRAW 12. Вместе с тем, ее функциональные возможности существенно шире, чем у других известных программ подобного типа (Macromedia FreeHand и Adobe Illustrator). 
надеюсь это подойдёт. когда то писала такое 5 получила

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Придумайте задачу, для решения которой необходимо использовать оператор выбора, составьте программу для её решения.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Marina658
muzeynizhn
palmhold578
servik78
АлександрАлександровна
Виктория Нина
andrey4work918
Shelchkowa453
moisalexx7
Vladimirovich351
Vika-simonenko
pedalplanet
palosik7621
Рожков Зейдан460
ivan-chay19