Поделитесь своими знаниями, ответьте на вопрос:
Организация ввода и вывода данных с использованием файлов 1. Для выполнения операций с логическими данными в языке Паскаль используют обозначение 1) real 2) integer 3) char 4) boolean 2. Запишите, как на языках программирования называ¬ют число, определяющее количество позиций на экране, которые занимает выводимая величина. Запишите, как на языках программирования называют запись алгоритмов. 4. Для выполнения операций с целочисленными данными в языке Паскаль используют обозначение 1) real 2) integer 3) char 4) boolean 5. После выполнения программы, записанной на языке Паскаль program prim; var s: integer; begin s:=15; write (‘s=’, s) end. на экран будет выведено s:=15 s=15 ‘s=’15 s= 15 Типовые задачи обработки массивов 1. Сколько единиц в двоичной записи десятичного числа 519? 2. Сколько нулей в двоичной записи десятичного числа 507? 3. Переведите в десятичную систему двоичное число 1010012. 4. Вычислите: 101011012 − 2558 + D16. ответ запишите в десятичной системе счисления. В ответе запишите только число, основание системы счисления писать не нужно. 5. Укажите наименьшее четырёхзначное шестнадцатеричное число, двоичная запись которого содержит ровно 6 нулей. В ответе запишите только само шестнадцатеричное число, основание системы счисления указывать не нужно. Символьный тип данных 1. Какой тип данных в языке Pascal предназначен для хранения символьной информации? 1) byte 2) integer 3) real 4) char 2. Какой тип данных в языке Pascal предназначен для хранения строковой информации? 1) integer 2) char 3) string 4) byte 3. Что является результатом функций, предназначенных для выполнения операций над строками? 1) Только число. 2) Только строка. 3) Строка или число. 4. Функция для определения длины строки 1) ord(x) 2) length(x) 3) pred(x) 4) round(x) 5. Процедура УДАЛЯЕТ из строки ST участок, содержащий N символов с позиции P. 1) Delete(st, p, n) 2) val(st, p, n) 3) insert(st, p, n)
У меня получилось минимальное - 2000.
1)
c = 2000 mod 2;
c = 0 -> a = 0 + 1.
x = 2000 div 10.
2) c = 200 mod 2;
c = 0 -> a = 1 + 1.
x = 200 div 10.
3) c = 20 mod 2.
c = 0 -> a = 2 + 1.
x = 20 div 10.
4) c = 2 mod 2.
c = 0 -> a = 3 + 1.
x = 2 div 10.
Итого на выводе получаем (4 0), что и нужно было.