sveta740450
?>

Написать программу, которая сортирует массив из N целых случайных чисел из диапазона [10; 40] и выводит на экран в две строки массив в исходном и отсортированном виде (по возрастанию Протестировать программу на значениях N: 5, 10, 20.

Информатика

Ответы

kamalfayed229
//PascalABC.Net 3.0, сборка 1064
type
  IntArray = array of integer;

var
  rows, cols: integer;
  M: array of IntArray;

begin
  Write('Количество строк и столбцов матрицы: '); Read(rows, cols);
  var Avg: array of double := new double[cols];
  M := new IntArray[rows];
  SetLength(Avg, cols);
  for var i := 0 to rows - 1 do
  begin
    M[i] := ArrRandom(cols, -25, 25);
    M[i].Println(#9)
  end;
  for var j := 0 to cols - 1 do
    Avg[j] := Range(0, rows - 1).Select(x -> M[x, j]).Average;
  Writeln('Наименьшее среднее по столбцам равно ', Avg.Min)
end.

Тестовое решение:
Количество строк и столбцов матрицы: 5 8
-22    -8    12    7    3    -18    8    22
2    -16    17    -13    -10    0    -19    2
20    -21    -6    13    2    -20    25    24
-7    -3    -2    -10    -2    8    18    23
4    -21    -8    8    23    -12    -13    -5
Наименьшее среднее по столбцам равно -13.8
tanyamurashova11352
// PascalABC.NET 3.0, сборка 1150 от 22.01.2016
begin
  var n:=ReadInteger('Количество элементов массива ');
  var m:=ArrRandom(n,-50,50); m.Println(', ');
  var a:=0; var b:=0; var c:=0;
  for var i:=0 to n-1 do begin
    if m[i]>0 then a:=a+m[i];
    if m[i]<m[b] then b:=i;
    if m[i] mod 5 = 0 then Inc(c)
  end;
  var w:=(b+1)+a/(c+1);
  WritelnFormat('A={0}, B={1}, C={2}, W={3}',a,b+1,c,w);
  Writeln('Принято, что элементы массива нумеруются от единицы')
end.

Тестовое решение:
Количество элементов массива  13
-43, -15, 18, -8, -13, -47, -36, 6, -16, 45, 33, 33, -24
A=135, B=6, C=2, W=51
Принято, что элементы массива нумеруются от единицы

Составить программу вычисления, w = b + a - сумма положительных элементов массива; b – номер наимень

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая сортирует массив из N целых случайных чисел из диапазона [10; 40] и выводит на экран в две строки массив в исходном и отсортированном виде (по возрастанию Протестировать программу на значениях N: 5, 10, 20.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

deputy810
Александровна
родичева1812
pivenraisa
zaschitin48
daverkieva568
SERGEI124
snab54
Сергей_Крутикова114
magazintrofey
dmitrymakarov003
Витальевна
Нескажу25
bellaalya13862
Annabill1987
▲