garikman-flesh486
?>

Начертить блок схемы к задачам из питона «Минимум из двух чисел» Даны два целых числа. Выведите значение наименьшего из них; «Шахматная доска» Заданы две клетки шахматной доски. Если они покрашены в один цвет, то выведите слово YES, а если в разные цвета — то NO. Программа получает на вход четыре числа от 1 до 8 каждое, задающие номер столбца и номер строки сначала для первой клетки, потом для второй клетки; «Високосный год Дано натуральное число. Требуется определить, является ли год с данным номером високосным. Если год является високосным, то выведите YES, иначе выведите NO. Напомним, что в соответствии с григорианским календарем, год является високосным, если его номер кратен 4, но не кратен 100, а также если он кратен 400. Шоколадка Шоколадка имеет вид прямоугольника, разделенного на n×m долек. Шоколадку можно один раз разломить по прямой на две части. Определите, можно ли таким образом отломить от шоколадки часть, состоящую ровно из k долек. Программа получает на вход три числа: n, m, k и должна вывести YES или NO.» Сколько совпадает чисел Даны три целых числа. Определите, сколько среди них совпадающих. Программа должна вывести одно из чисел: 3 (если все совпадают), 2 (если два совпадает) или 0 (если все числа различны

Информатика

Ответы

Тарбаева1243
#include <iostream>
#include <conio.h>
#include <time.h>
using namespace std;

void main()
{
 srand(time(NULL));
 setlocale(0, "");
 int arr[17];
 int a, b, chet=0, nechet = 0;
cout << "Введите диапазон ." << endl << "Нижняя граница диапазона: "; cin >> a; cout << "Верхняя граница диапазона: "; cin >> b; cout << endl;
for (int i = 0; i < 17; ++i)
{
  arr[i] = a + rand() % (b-a+1);
  cout <<" "<<arr[i];
}
for (int i = 0; i < 17; ++i)
{
  if (arr[i] % 2 == 0) chet++;
 else nechet++;
} if (chet > nechet)
 cout << " \n Четных больше";
else if (nechet>chet)
 cout << "\n Нечетных больше";
else cout << "\n Одинаковое количество четных и нечетных";
 _getch();
}
rashad8985

ответ: Функция ОКРУГЛ

Осуществляет стандартное округление, а именно округляет число до ближайшего разряда с указанной точностью.

Синтаксис: =ОКРУГЛ(число; число_разрядов), где

Число – обязательный аргумент. Число либо ссылка на ячейку, его содержащую;

Число_разрядов – обязательный аргумент. Указывает, какое количество знаков после запятой необходимо оставить:

0 – округление до целого числа;

1 – округление до десятых долей;

2 – округление до сотых долей;

И т.д.

Аргумент может также принимать отрицательные числа:

-1 – округление до десятков;

-2 – округление до сотен;

И т.д.

Пример использования:

=ОКРУГЛ(5,45;0) – формула возвращает значение 5.

=ОКРУГЛ(5,45;1) – формула возвращает значение 5,5.

=ОКРУГЛ(5,45;3) – не меняет число, т.к. указанное число разрядов превышает его точность.

=ОКРУГЛ(5,45;-1) – формула возвращает значение 10.

Функция ОТБР

Отбрасывает дробную часть числа. Отличие от предыдущей функции заключается в том, что число по факту не округляется, а только усекается до указанного разряда.

Синтаксис: =ОТБР(число; [число_разрядов]), где

Число – обязательный аргумент. Число либо ссылка на ячейку с числом;

Число_разрядов – необязательный аргумент. Указывает, какое количество знаков после запятой необходимо оставить:

0 – точность до целого числа;

1 – точность до десятых долей;

2 – точность до сотых долей;

И т.д.

Пример использования:

=ОТБР(5,45;0) – формула возвращает значение 5.

=ОТБР(5,85;0) – так же возвращает значение 5.

=ОТБР(5,45;1) – возвращает значение 5,4.

=ОТБР(5,45;3) – формула не меняет число, т.к. указанное количество разрядов превышает его точность.

Функция ОКРУГЛВВЕРХ

Производит округление до ближайшего большего по модулю числа с указанной точностью.

Синтаксис: =ОКРУГЛВВЕРХ(число; число_разрядов), где

Число – обязательный аргумент. Число либо ссылка на ячейку, содержащую число;

Число_разрядов – обязательный аргумент. Указывает, какое количество знаков после запятой необходимо оставить:

0 – округление до целого числа;

1 – округление до десятых долей;

2 – округление до сотых долей;

И т.д.

Аргумент может также принимать отрицательные числа:

-1 – округление до десятков;

-2 – округление до сотен;

И т.д.

Пример использования:

=ОКРУГЛВВЕРХ(5,001;0) – формула возвращает значение 6.

=ОКРУГЛВВЕРХ(-5,001;0) – формула возвращает значение -6, т.к. -6 по модулю больше, чем -5,001 по модулю.

=ОКРУГЛВВЕРХ(5,45;1) – возвращает значение 5,5.

=ОКРУГЛВВЕРХ(5,45;3) – функция не изменяет число, т.к. требуемая разрядность превышает его точность.

=ОКРУГЛВВЕРХ(5,45;-1) – формула возвращает значение 10.

Функция ОКРУГЛВНИЗ

Аналогична предыдущей функции, за исключением того, то округляет число в меньшую сторону по модулю с указанной точностью.

Пример использования:

=ОКРУГЛВНИЗ(5,99;0) – формула возвращает значение 5.

=ОКРУГЛВНИЗ(-5,99;0) – формула возвращает значение -5, т.к. -5 по модулю меньше, чем -5,99 по модулю.

=ОКРУГЛВНИЗ(5,45;1) – функция возвращает значение 5,4.

=ОКРУГЛВНИЗ(5,45;3) – не меняет число, т.к. указанная разрядность превышает его точность.

=ОКРУГЛВНИЗ(5,45;-1) – формула возвращает значение 0.

Функция ОКРУГЛТ

Округляет число до ближайшего кратного числу, заданного вторым аргументом.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Начертить блок схемы к задачам из питона «Минимум из двух чисел» Даны два целых числа. Выведите значение наименьшего из них; «Шахматная доска» Заданы две клетки шахматной доски. Если они покрашены в один цвет, то выведите слово YES, а если в разные цвета — то NO. Программа получает на вход четыре числа от 1 до 8 каждое, задающие номер столбца и номер строки сначала для первой клетки, потом для второй клетки; «Високосный год Дано натуральное число. Требуется определить, является ли год с данным номером високосным. Если год является високосным, то выведите YES, иначе выведите NO. Напомним, что в соответствии с григорианским календарем, год является високосным, если его номер кратен 4, но не кратен 100, а также если он кратен 400. Шоколадка Шоколадка имеет вид прямоугольника, разделенного на n×m долек. Шоколадку можно один раз разломить по прямой на две части. Определите, можно ли таким образом отломить от шоколадки часть, состоящую ровно из k долек. Программа получает на вход три числа: n, m, k и должна вывести YES или NO.» Сколько совпадает чисел Даны три целых числа. Определите, сколько среди них совпадающих. Программа должна вывести одно из чисел: 3 (если все совпадают), 2 (если два совпадает) или 0 (если все числа различны
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

deadnobody
Serezhkin
Татьяна902
Nataliatkachenko1
set907
lechic3
platonm777639
sanyaborisov910067
teya07
Alyona
Drugov_Vladimirovna
zibuxin6
alex13izmailov
Александровна-Грузман
info32