zaseche99
?>

Даны два вещественных числа a и b, если сумма этих чисел больше 35, то увеличить их в 4 раза иначе уменьшить в 2 раза. Программа паскаль

Информатика

Ответы

ekasatkina

program vld;

var

a,b : real;

begin

writeln('Введите 2 числа: ');

readln(a,b);

if a+b >35 then

 begin

 a := a *4;

 b := b * 4

 end

else

 begin

 a := a / 2;

b := b / 2;

end;

writeln(a);

writeln(b);

end.

Константиновна

begin

 var (a, b) := ReadReal2;

 if a + b > 35 then

   (a, b) := (a * 4, b * 4)

 else

   (a, b) := (a / 2, b / 2);

 Print(a, b)

end.

Язык - PascalABC.NET

spodobnyi

Саша - вышивание, Маша - танцы, Валя - рисование.

Объяснение:

Либо часть про Сашу, либо про Машу ложна (два верных утверждения быть не может). Тогда либо Саша занимается вышиванием, либо Маша - рисованием.

1) Саша занимается вышиванием. Тогда Валя не может заниматься вышиванием, её часть гарантированно ложна. Значит, верно утверждение про Машу: она не занимается рисованием, ей остаются танцы. Получается, Валя занимается рисованием.

2) Маша занимается рисованием. Остается два высказывания: Саша не занимается вышиванием, Валя - занимается вышиванием. Одно из этих утверждений истинно, другое ложно. Но если истинно первое, то обе девочки не занимаются вышиванием, если истинно второе - обе занимаются. Такого быть не может, поэтому Маша не может заниматься рисованием.

vahmistrova

#include <iostream>
using std::cout;
using std::endl;
using std::fixed;
#include <cstdlib>
using std::rand;
using std::srand;
#include <ctime>
using std::time;
#include <iomanip>
using std::setprecision;

int main()
{
    float a[16];
    float counter = 0;

    srand(time(0));

    for(int i = 0; i < 16; i++)
    {
        a[i] = float(rand()) / RAND_MAX * (3.0 + 2.0) - 2.0;

        if(a[i] < 0.0)
        {
            counter += a[i];
        }

        cout << setprecision(2) << fixed << a[i] << endl;
    }
    cout << endl;

    cout << "Sum = " << counter << endl;

   return 0;
}


Составьте программу, которая формирует массив, содержащий 16 случайных вещественных чисел, принадлеж

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны два вещественных числа a и b, если сумма этих чисел больше 35, то увеличить их в 4 раза иначе уменьшить в 2 раза. Программа паскаль
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

snip99
info664
aza2103
olgavlad199
minasov19
elena-ruzadom
victors
ktatarinova
Sergei Gaishun
Анна1169
skrepka397412
n-896458
avetisov-84850
Allahverdi_Мария475