mvinogradov6
?>

Подпрограмма. Процедура заранее! Составить программу, которая меняет у пяти любых чисел, вводимых с клавиатуры, порядок следования цифр в числе на обратный. В качестве процедуры применяется серия команд, определяющая состав числа и выводящая число в обратном порядке. Для этого используется цикл While с условием x<>0, где х – любое число вводимое с клавиатуры. Внутри цикла сначала определяется цифры, стоящая в конце числа, через mod, затем эта цифра выводится на экран, а дальше идет уменьшение самого числа х через div. В основной программе используется цикл For для ввода с клавиатуры 5 любых чисел. ​

Информатика

Ответы

valeron7hair7

P =NP

Объяснение:

создаем переменую х и у

и содаем перемную х 1 и  у1

P равно х и игрек

NP равно х 1 и  у1

теперь P =NP

проверяем в системе кординат например 8 на 8

мы видим равенство класов

смотри мы можем сделать так

допустим это книга с пронумероваными страницами

каждая страница собщаеть какой диапазон значение на даном поле

но если мы будем сравнивать первая клетка и каждую последущую перебором это будет  долго

мы можем наложить поле на поле   и проверить сразу два значения  и сравнить их отельно

то есть  найдя на страничке  список номеровмы можем сразу  выводить значения из поля  и передать еще одной переменой проверить  были совпадения или нет

nat63nesnova5

#include <iostream>

int main() {

const int SIZE = 10;

bool isSence = false;

int sum = 0;

int count = 0;

int arr[SIZE];

for (int i = 0; i < SIZE; i++)

{

 arr[i] = rand() % 20 - 10; // "рандомно" заполняем массив от -10 до 10

 std::cout << arr[i] << "\t"; // выводим массив в консоль

 if (arr[i] >= 0)

  isSence = true;

}

for (int i = 0; i < SIZE; i++)

{

 if ((isSence) && (arr[i] > 0))

  sum += arr[i]; //sum = sum + arr[i];

  count++;

}

if (isSence)

 std::cout << "\nсреднее арифметическое положительных чисел = " << double(sum) / count << std::endl; // явное приведение типов

else

 std::cout << "\nВ массиве нету положительных чисел или нету нулей и/или отрицательных чисел" << std::endl;

return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Подпрограмма. Процедура заранее! Составить программу, которая меняет у пяти любых чисел, вводимых с клавиатуры, порядок следования цифр в числе на обратный. В качестве процедуры применяется серия команд, определяющая состав числа и выводящая число в обратном порядке. Для этого используется цикл While с условием x<>0, где х – любое число вводимое с клавиатуры. Внутри цикла сначала определяется цифры, стоящая в конце числа, через mod, затем эта цифра выводится на экран, а дальше идет уменьшение самого числа х через div. В основной программе используется цикл For для ввода с клавиатуры 5 любых чисел. ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

yulialoveinthelow2010
Радецкая264
Александра Викторович531
optima3559
mnogoz
horizma609
fox-cab3444
priemni451
Bella
Павловна897
o-kate17
Faed_Arakcheeva
shumeikoElena362
Ivan1568
dianakryukova00