ekrosenergoserv
?>

Изучить п.3.2.1 и 3.2.3. Задачу на стр. 118 разобрать. Взяв за образец задачу снизу, составить программу и пояснение к следующей задаче. Вычислить объем куба, по формуле v=a3

Информатика

Ответы

morozovalexander90

8.   cos(x) - ((abs(x-2))/(sqrt(x)+3))+sqr(1+x)

9.   а = 10       b = 10       c = 20

Объяснение:

9.

а = 25       b = 16

пока условие (а + b) > 20 истинно   (да) выполнить

Действия в цикле:

1) а = а - 5

2) b = b - 2

c = а + b

а = 25       b = 16

(25 + 16) > 20       41 > 20       (да)

Действия в цикле:

1) а = 25 - 5 = 20

2) b = 16 - 2  = 14

а = 20       b = 14

(20 + 14) > 20       34 > 20       (да)

Действия в цикле:

1) а = 20 - 5 = 15

2) b = 14 - 2  = 12

а = 15       b = 12

(15 + 12) > 20       27 > 20       (да)

Действия в цикле:

1) а = 15 - 5 = 10

2) b = 12 - 2  = 10

а = 10       b = 10

(10 + 10) > 20       20 > 20       (нет)

Цикл не выполняется

а = 10       b = 10

c = а + b = 10 + 10 = 20

а = 10       b = 10       c = 20

zipylin

#define _USE_MATH_DEFINES

#include <iostream>

#include <math.h>

using namespace std;

int main()

{

 double a, b, alpha, s;             // объявления переменных

 setlocale(LC_ALL, "Russian");

 cout << "\nБольшее основание: ";   // ввод с клавиатуры

 cin >> a;

 cout << "\nМеньшее основание: ";

 cin >> b;

 cout << "\nУгол при большем основании: ";

 cin >> alpha;

 s = a * b / sin(alpha * M_PI / 180);  // расчет площади трапеции , * M_PI / 180 для перевода градусов в радианы

 cout << "\nПлощадь трапеции = " << s;

}

Объяснение:

#define _USE_MATH_DEFINES

#include <math.h>

эти две строки для M_PI, можно просто заменить на 3.14

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Изучить п.3.2.1 и 3.2.3. Задачу на стр. 118 разобрать. Взяв за образец задачу снизу, составить программу и пояснение к следующей задаче. Вычислить объем куба, по формуле v=a3
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Шиморянов Мария1866
АнжелаВасильевич
Беспалова
Rizhov Alekyan325
Михайлов
afoninia
andreyduborezz2913
choia
docvet4
Yurkov
озерская_Мария1234
Avetisyan575
zharovaleks
pechyclava
Вадим-Рашад323