Мирзоев Денис
?>

Решить хотя бы 1-2 2. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 2 и не оканчивающихся на 0. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность В последовательности всегда имеется число, удовлетворяющее условию Программа должна вывести одно число: количество чисел, кратных 2 и не оканчивающихся на 0. 3. Напишите программу, которая в последовательности натуральных чисел определяет произведение чисел, кратных 3 и оканчивающихся на 3. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). В последовательности всегда имеется число, удовлетворяющее условию Программа должна вывести одно число: произведение чисел, кратных 3 и оканчивающихся на 3. 4. Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 4, или сообщает, что таких чисел нет (выводит NO). Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 признак окончания ввода, не входит в последовательность). Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести среднее арифметическое чисел, кратных 4 или вывести «NO», если таких чисел нет

Информатика

Ответы

baron

Program M1;

var s,x:integer;

begin

s:=0;

x:=1;

while x<>0 do

begin

read(x);

if (x mod 7=0) and (i mod 10=0) then s:=x+s;

end;

writeln(summa=,s);

end.

Irina Bakaev
      численность           население через год   1   40000                             42000   2   42000                             44100   3   44100                             46305 переменная 1 = 3 переменная 2 =  46305    
Varezka86179
Носитель информации - это любой материальный объект, используемый для закрепления и хранения на нем информации.
В современном обществе можно выделить три основных вида носителей информации:
1) бумажный;
2) магнитный;
3) оптический.
Бумажные носители информации.
Одним из самых распространенных носителей информации является бумага. В школе мы записываем информацию в тетради, теоретический материал изучаем по учебникам, при разработке доклада, реферата или другого сообщения необходимые сведения мы находим в других источниках (книгах, энциклопедиях, словарях и т. д) , которые в свою
очередь являются бумажными носителями информации
Первые вычислительные машины работали на перфокартах. Перфокарты делали из плотной бумаги- картона, на которые по определенному правилу с специального «станка» - перфоратора наносили отверстия в виде
небольших дырочек.
Магнитные носители информации
В 1928 году была изготовлена первая магнитная лента. Наши бабушки и дедушки слушали музыку на магнитофонах с магнитной лентой, которую называли «Бабина» .
Магнитная лента оказалась достаточно надежным, долговечным и доступным каждому носителем информации.
В первых ЭВМ (электронно- вычислительных машинах) информация хранилась на магнитных лентах и магнитных дисках
В современных компьютерах в качестве носителя информации используются следующие магнитные носители :
1) дискета (на которую можно поместить данные 3000 перфокарт) .
. Внутри пластмассового корпуса расположен гибким магнитный диск, поверхность которого покрыта специальным магнитным веществом. Информация записывается на обе его поверхности. Чтобы при работе с дискетой ее не надо было переворачивать, внутри флоппи-дисковода (устройства, которое записывает или считывает информацию с дискеты) имеется две магнитные головки, каждая для своей стороны дискеты. Такой диск требует особого обращения, магниты, повышенная температура и влажность разрушают хранящуюся на нем информацию.
2) жесткий магнитный диск или винчестер ( хранит 100 000 и более дискет) . Внутри жесткого металлического корпуса находятся несколько десятков дисков магнитных дисков, размещенных на одной оси . Запись или считывание информации обеспечивается несколькими магнитными головками. В целях сохранения информации и работо жесткие магнитные диски необходимо оберегать от ударов и резких изменений положений системного блока (нельзя наклонять и переворачивать в процессе работы) .
3) стриммеры (стрим-картриджи) - устройства, обеспечивающие запись или считывание звуковой информации . Внутри данного носителя находится магнитная лента.
Оптические носители информации
Самым распространенными носителями информации являются оптические или лазерные диски .
Лазерные диски изготавливают из пластмассы, сверху покрывают тонким слоем из металла и прозрачным лаком, защищающим от незначительных царапин или загрязнений. Запись или считывание информации в CD-дисководе осуществляется с света лазера. При записи лазерный луч выжигает на поверхности диска микроскопические углубления, кодируя тем самым информацию (при считывании -лазерный луч отражается от поверхности вращающегося диска) . Такие диски следует оберегать от пыли и царапин.
Различают CD и DVD диски.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить хотя бы 1-2 2. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 2 и не оканчивающихся на 0. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность В последовательности всегда имеется число, удовлетворяющее условию Программа должна вывести одно число: количество чисел, кратных 2 и не оканчивающихся на 0. 3. Напишите программу, которая в последовательности натуральных чисел определяет произведение чисел, кратных 3 и оканчивающихся на 3. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). В последовательности всегда имеется число, удовлетворяющее условию Программа должна вывести одно число: произведение чисел, кратных 3 и оканчивающихся на 3. 4. Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 4, или сообщает, что таких чисел нет (выводит NO). Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 признак окончания ввода, не входит в последовательность). Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести среднее арифметическое чисел, кратных 4 или вывести «NO», если таких чисел нет
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

okasnab
elozinskaya
mbudilina
chumakanna17
yatania-popovich7
Stepanovich_Makarov
nataliaterekhovasinger2
subbotinlan
Liliya1106
lider123
mahalama7359
saljagindima
Viktorovna
Misyura_Viktoriya1683
parolmm
▲