nikziam
?>

Дана структура struct time { int hour; int min; int sec ;}; Пользуясь таким структурным типом, составить программу, определяющуу предшествует ли время t1 времени t2(в пределах суток пользуясь c#

Информатика

Ответы

NurlanAleksandrovich

using System;

namespace ConsoleApp1

{

   struct time

   {

       public int hour;

       public int min;

       public int sec;

   };

   class Program

   {

       static void Main(string[] args)

       {

           time t1; t1.hour = 18; t1.min = 45; t1.sec = 23;

           time t2; t2.hour = 18; t2.min = 45; t2.sec = 24;

           if (t1.hour < t2.hour) Console.WriteLine("Время t1 предшествует t2");

           else if ((t1.hour == t2.hour)&&(t1.min < t2.min)) Console.WriteLine("Время t1 предшествует t2");

           else if ((t1.hour == t2.hour) && (t1.min == t2.min) && (t1.sec < t2.sec)) Console.WriteLine("Время t1 предшествует t2");

           else Console.WriteLine("Время t1 не предшествует t2");

       }

   }

}

fullhouse9991

АХТУНГ!

Произведение может вылетать за лимиты Long Long.

Ведь лимит лонг лонг вправо есть 9 223 372 036 854 775 807

И если увеличить количество чисел в массиве, допустим, до 100, то в теории может выйти 100^100 и это невесело.

#define COUNT 10

#define LIMIT 100

#include <iostream>

#include <ctime>

#include <random>

using namespace std;

int main() {

srand(time(NULL));

int a [COUNT];

long long result = 1;

for (int i = 0; i < COUNT; ++i)

 a[i] = rand()%(LIMIT-0+1) + 0;

for (int i = 0; i < COUNT; ++i)

 if (a[i] % 6 != 0 && a[i] > 9 && a[i] < 100 && a[i] != 0)

  result *= a[i];

cout << "Massive: ";

for (int i = 0; i < COUNT; ++i)

 cout << a[i] << " ";

cout << endl << "RESULT: " << result;

}

krasnobaevdj3
Type Mass = array[1..50,1..50] of integer;

Procedure ABC(Var A:Mass; Var Max:integer);
Var
   i,j:integer;
Begin
Write('M = ');ReadLn(i);
Write('N = ');ReadLn(j);
For i:= 1 to i do
    Begin
    For j:= 1 to j do
        Begin
        A[i,j]:=random(21)-10;
        Write(A[i,j]:3,' ')
        End;
    WriteLn;
    End;
{Поиск максимума}
Max:=A[1,1];
For i:= 1 to i do
    For j:= 1 to j do
        if A[i,j]>Max then Max:=A[i,j];
End;

Var
   A,B,C:Mass;
   MaxMax,Max:integer;
Begin
Randomize;
WriteLn('Массив A(M,N):');
ABC(A,Max);
WriteLn('Max(A) = ',Max);
MaxMax:=Max;
WriteLn;

WriteLn('Массив B(M,N):');
ABC(B,Max);
WriteLn('Max(B) = ',Max);
if MaxMax<Max then MaxMax:=Max;
WriteLn;

WriteLn('Массив C(M,N):');
ABC(C,Max);
WriteLn('Max(C) = ',Max);
if MaxMax<Max then MaxMax:=Max;
WriteLn;

WriteLn('Max(Max(A),Max(B),Max(C)) = ',MaxMax);
End.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дана структура struct time { int hour; int min; int sec ;}; Пользуясь таким структурным типом, составить программу, определяющуу предшествует ли время t1 времени t2(в пределах суток пользуясь c#
Ваше имя (никнейм)*
Email*
Комментарий*