znaberd786
?>

Дан массив из N натуральных чисел. Создать массив из четных чисел этого массива. Если таких чисел нет, то вывести сообщение об этом факте. программа в с написать программу

Информатика

Ответы

Karlova1507

#include <iostream>

#include <cmath>

using namespace std;

#define ld long double

struct triangle{

   ld a;

   ld b;

   ld c;

};

ld square(triangle t){

   ld p = (t.a + t.b + t.c)/2;

   return sqrt(p * (p - t.a) * (p - t.b) * (p - t.c));

}

triangle t1,t2;

void solve(){

   if(square(t1) == square(t2))

       cout << "ИСТИНА";

   else

       cout << "ЛОЖЬ";

}

signed main() {

   ios_base::sync_with_stdio(0);

   cin.tie(0);

   cout.tie(0);

   cin >> t1.a >> t1.b >> t1.c >> t2.a >> t2.b >> t2.c;

   solve();

}

dddddd68

using System;

namespace ConsoleApp5

{

   class Program

   {

       static void Main(string[] args)

       {

           bool f;

           double a,b,c, s, s1;

           a = double.Parse(Console.ReadLine());

           b = double.Parse(Console.ReadLine());

           c = double.Parse(Console.ReadLine());

           s = Math.Sqrt(((a + b + c) / 2) * (((a + b + c) / 2) - a) * (((a + b + c) / 2) - b) * (((a + b + c) / 2) - c));

           a = double.Parse(Console.ReadLine());

           b = double.Parse(Console.ReadLine());

           c = double.Parse(Console.ReadLine());

           s1= Math.Sqrt(((a + b + c) / 2) * (((a + b + c) / 2) - a) * (((a + b + c) / 2) - b) * (((a + b + c) / 2) - c));

           if (s == s1)

               f = true;

           else

               f = false;

           Console.WriteLine(f);

           Console.ReadKey();

       }

   }

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дан массив из N натуральных чисел. Создать массив из четных чисел этого массива. Если таких чисел нет, то вывести сообщение об этом факте. программа в с написать программу
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tigran87-87
Alesander-Isaev684
korotinadasha07
ribcage52
lebedevevgen
ivanjeka87
Vladimirovna1858
filantropagv4
Константиновна
eobmankina
zoomagazinkotmatroskin
platonm777639
EkaterinaSEMENOV702
aromastil88
vovlyur