

Какой оператор цикла желательно использовать, если известно число повторений тела цикла?
repeat <оператор1, …>until <условие>
while <условие>do <оператор>
for <параметр>:= <начальное значение>to<конечное значение> do<оператор>
2. Используется оператор for i:= -10 to 10 do…
После завершения выполнения тела цикла i = 10
3. Цикл в фрагменте программы
p:=1;
repeat
p:=p*0.1
until p>0.1;
будет исполнен:
1 раз
2 раза
бесконечное число раз
0 раз
3 раза
4. Цикл в фрагменте программы
a:=1;
b:=1;
while a+b<8 do
begin
a:=a+1; b:=b+2
end;
выполнится:
0 раз
3 раза
2 раза
1 раз
бесконечное число раз
5. Какой оператор цикла желательно использовать для записи алгоритмической конструкции, изображённой на схеме?
НЕТ СХЕМЫ. ОТВЕТИТЬ НА ВОПРОС НЕВОЗМОЖНО.
while <условие> do <оператор>
for <параметр>:= <начальное значение> to <конечное значение> do <оператор>
repeat <оператор1, …> until <условие>
6. Какой оператор цикла желательно использовать, если известно условие выхода из цикла?
repeat <оператор1, …> until <условие>
for <параметр>:= <начальное значение> to <конечное значение> do <оператор>
while <условие> do <оператор>
7. Определите, какое значение будет выведено на экран в результате выполнения приведенной ниже последовательности операторов:
a:=1; b:=1;
while a<=32 do a:=a*2; b:=b*a; //Обратите внимание! Нет begin end.
write (b)
32
256
64
128
8. Используется оператор for i:= -5 to 9 do…
При первом выполнении тела цикла i = -5
9. Чему равно значение переменной s после выполнения следующего фрагмента программы
Фрагмента программы нет! Задание решить нельзя!
Поделитесь своими знаниями, ответьте на вопрос:
var a: array [1..5] of integer;
i, j , count: integer;
repeated : boolean;
begin
for i := 1 to 5 do
begin
write('Введите ', i, '-e число: ');
readln(a[i]);
end;
for i := 1 to 5 do
begin
repeated := false;
for j := 1 to i - 1 do
if (a[i] = a[j]) then
repeated := true;
if repeated then continue;
count := 1;
for j:= i+1 to 5 do
if (a[i]=a[j]) then
inc(count);
writeln('Число ', a[i], ' встречается ', count,' раз');
end;
end.