rozhkova
?>

Написать программу на паскале Вычислить разность, деление, умножение двух чисел а, в)

Информатика

Ответы

Сорокина-Светлана

Объяснение:

Решение во вложении


Написать программу на паскале.( Вычислить разность, деление, умножение двух чисел а,в)
jeep75

javascript: function Пр(ч) { var стр = ч.toString(); for (let сч = 1; сч < стр.length; сч++) { let ч1 = parseInt(стр.substring(0, сч)), ч2 = parseInt(стр.substring(сч)); if (ч1 > ч2) continue; let к1 = Math.sqrt(ч1), к2 = Math.sqrt(ч2); if (к1 == Math.floor(к1)) { for (let сч1 = 1; сч1 < 10 && сч1 < ч2 - 1; сч1++) for (let сч2 = 1; сч2 * сч2 + сч1 * сч1 <= ч2; сч2++) if (сч2 * сч2 + сч1 * сч1 == ч2 && Math.pow(сч1 + сч2, 2) == ч1) return ч + ": " + сч1 + ", " + сч2; } if (к2 == Math.floor(к2)) { for (let сч1 = 1; сч1 < 10 && сч1 < ч1 - 1; сч1++) for (let сч2 = 1; сч2 * сч2 + сч1 * сч1 <= ч1; сч2++) if (сч2 * сч2 + сч1 * сч1 == ч1 && Math.pow(сч1 + сч2, 2) == ч2) return ч + ": " + сч1 + сч2; } }; return ч + ": -"; } [2949, 10, 11, 25, 95, 2036, 3264, 6581].forEach(function (зн) { alert(Пр(зн)); });

alexkortyukov
Program abc;Const  n=3;  m=3;Var  a:array[1..n,1..m] of integer;  b,y,i,j,sum:integer;  srd:real;  Begin  Writeln('Введите числа массива: ');    For i:=1 to n do      For j:=1 to m do      Begin        Write('a[',i,',',j,']= ');        Readln(a[i,j]);        if a[i,j]>0 then           begin             sum:=sum+a[i,j];            inc(b);          end         else          If a[i,j]<0 then            Inc(y);       End;     If sum>0 then      begin       srd:=sum/1      b;      Writeln('Среднее =',srd);      end      else      Writeln('Нет положительных членов массива');     If y>0 then      begin       Writeln('Количество отрицательных элементов =',y);      end      else      Writeln('Нет отрицательных членов массива');End.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на паскале Вычислить разность, деление, умножение двух чисел а, в)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

galinazajceva781
KonovalovKonstantinovna1306
jgaishun756
ananyananar
Filintver
Валентинович133
mirdetzhuk79
ibswoklol1362
Aleksandrovna-Marina
Nevstrueva_Vasilevna
masha812
Marina281
prostopo4ta29
universal21vek116
Tamara