Vasilevna_Utenkova651
?>

составьте программу для чтения отрывка из текста.Переключение его на Перевертыш и передача его на печать в том же варианте. Слово перевертыша переводится следующим образом: буквы, стоящие до первого гласного, перемещаются до конца слова и соединяются с окончанием quot; циусquot;. Например. a)" кот в сапогах " -- " откциус вциус апогахсциус" b) "пример перевода" -- " имерпрциус ереводапциус"

Информатика

Ответы

Рафаэль633

// PascalABC.Net

var vowel: set of char = ['а', 'у', 'о', 'ы', 'и', 'э', 'я', 'ю', 'ё', 'е'];

s, substr: string;

begin

  s := 'кот в сапогах';

  var words := s.Split(' ');

  for var i := 0 to words.length - 1 do

  begin

      for var j := 1 to words[i].Length do

          if words[i][j] in vowel then

          begin

              substr := Copy(words[i], 1, j-1);

              Delete(words[i], 1, j-1);

              words[i] += substr;

              break;

          end;

      words[i] += 'циус';

  end;

  writeln(words.JoinIntoString(' '));

end.

Valeria123864531
1. Для цикла For

var
  x,n,p:longint;
  i:integer;
begin
  readln (x,n);
  p:=1;
  for i := 1 to N do
    p:=p*x;
  writeln(x,' в степени ',n,' равно ',p );
end.

2. Для цикла While
var
  x,n,p:longint;
  i:integer;
begin
  readln (x,n);
  p:=1;
  i:=1;
  while i<=n do begin
    p:=p*x;
    i:=i+1;
  end;
  writeln(x,' в степени ',n,' равно ',p );
end.

3. Для цикла Repeat

var
  x,n,p:longint;
  i:integer;
begin
  readln (x,n);
  p:=1;
  i:=1;
  repeat
    p:=p*x;
    i:=i+1;
  until i>n;
  writeln(x,' в степени ',n,' равно ',p );
end.
Alex17841
Эту колдунью зовут Кодировка КОИ-8. Таблица кодирования: А-Ю, Б-А, В-Б, Г-Ц, Д-Д, Е-Е, Ж-Ф, З-Г, И-Х, Й-И, К-Й, Л-К, М-Л, Н-М, О-Н, П-О, Р-П, С-Я, Т-Р, У-С, Ф-Т, Х-У, Ц-Ж, Ч-В, Ш-Ь, Щ-Ы, Ъ-З, Ы-Ш, Ь-Э, Э-Щ, Ю-Ч, Я-Ъ, Ё-╦ Таблица построена так. Слева стоят буквы по русскому алфавиту, а справа русские буквы, соответствующие английскому алфавиту. @ - Ю (код 40), A - А (41), B - Б, C - Ц, D - Д, E - E, F - Ф, и т.д. Буква Ё - 33-ья в алфавите, она выбивается из ряда в 32 буквы, поэтому превращается не в букву, а в элемент псевдографики. И еще меняется регистр, 1-ая буква маленькая, остальные большие.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

составьте программу для чтения отрывка из текста.Переключение его на Перевертыш и передача его на печать в том же варианте. Слово перевертыша переводится следующим образом: буквы, стоящие до первого гласного, перемещаются до конца слова и соединяются с окончанием quot; циусquot;. Например. a)" кот в сапогах " -- " откциус вциус апогахсциус" b) "пример перевода" -- " имерпрциус ереводапциус"
Ваше имя (никнейм)*
Email*
Комментарий*