vladexi
?>

Задача:Размер файла V байт. Переведите в мегабайты и гигабайты.program z4;uses crt;var b, m, g:real;beginreadln(b);m:=b/1024;g:=m/1024;writeln (m, ' ', g);end.Задание:Измените текст программы в соответствии с видеоуроком. А именно:Вставьте перед командами readln(b) и writeln (m, ' ', g) строки, которые будут пояснять смысл исходной и результирующих величин.Отладьте программу в Паскале.4.Используя материал видеоурока напишите программу для решения задачи:Заработок папы a рублей в месяц, мамы – b рублей в месяц. В семье двое неработающих детей и дедушка. Пенсия дедушки c рублей. Какой средний доход в семье на одного человека?

Информатика

Ответы

Волков1968
1. 2. Имеются четыре основные составляющие информационной функции человека: прием (ввод) информации; запоминание информации (сохранение в памяти) ; процесс мышления (обработка информации) ; передача (вывод) информации. Компьютер включает в себя устройства, выполняющие эти функции мыслящего человека: устройства ввода; устройства запоминания — память; устройство обработки — процессор; устройства вывода.
3. В ходе работы компьютера информация через устройства ввода попадает в память. Затем процессор извлекает из памяти обрабатываемую информацию, работает с ней и помещает в нее результаты обработки. Полученные результаты через устройства вывода сообщаются человеку.
4.последовательность инструкций, предназначенная для исполненияустройством управления вычислительной машины. Программа — один из компонентов программногообеспечения. 
5.Главное отличие данных от программы в том, что первые являются носителем информационной нагрузки — файлами. Программа — средство создания, а также воспроизводства этой информационной нагрузки (в том виде, в котором она нужна пользователю).
andruhovich

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Threading.Tasks;

namespace Global

{

   class Program

   {

       static void Main(string[] args)

       {

           string first_x = Console.ReadLine();

           int first_input = Convert.ToInt16(first_x);

           int y = 1 - first_input;

           y = y + 3 * Get_x();

           y = y - 4 * Get_x();

           Console.Write(y);

           Console.Read();

       }

       static int Get_x()

       {

           string input = Console.ReadLine();

           int x = Convert.ToInt16(input);

           return x;

       }

   }

}

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задача:Размер файла V байт. Переведите в мегабайты и гигабайты.program z4;uses crt;var b, m, g:real;beginreadln(b);m:=b/1024;g:=m/1024;writeln (m, ' ', g);end.Задание:Измените текст программы в соответствии с видеоуроком. А именно:Вставьте перед командами readln(b) и writeln (m, ' ', g) строки, которые будут пояснять смысл исходной и результирующих величин.Отладьте программу в Паскале.4.Используя материал видеоурока напишите программу для решения задачи:Заработок папы a рублей в месяц, мамы – b рублей в месяц. В семье двое неработающих детей и дедушка. Пенсия дедушки c рублей. Какой средний доход в семье на одного человека?
Ваше имя (никнейм)*
Email*
Комментарий*