Поделитесь своими знаниями, ответьте на вопрос:
Тест Символьные строки 1. Какой тип данных используется в языке Паскаль для обозначения символьных строк? ответ: 2. Отметьте все правильные объявления символьных строк. var s: string;var string: s;vars, s1, s2: array[1..10] of char; var s1, s2: integer; var s, s1, s2: string; 3. Что будет выведено на экран после выполнения программы? s := '123'; s := s + '0' + s; s := s + s;writeln ( s ); ответ: 4. Что будет выведено на экран после выполнения этой программы? s := '123'; s := s + s[2] + s + s[3]; writeln ( s ); ответ: 5. Что будет выведено на экран после выполнения этой программы? s := '12345'; n := Length(s) + Length('456'); writeln ( n ); ответ: 6. Что будет выведено на экран после выполнения программы? s := '123456789'; s1 := 'abcdef'; s := Copy(s, 5, 2) + '0' + Copy(s1, 3, 3); writeln ( s ); ответ: 7. Что будет выведено на экран после выполнения этой программы?s := '123456'; q := 'abc';Delete ( s, 2, 3 ); Insert ( s, q, 2 ); writeln ( q ); ответ: 8. Что будет выведено на экран после окончания работы программы?s := '123456789'; Delete ( s, 1, 2 ); n := Pos ( '6', s ); writeln ( n ); ответ: 9. Что будет выведено на экран после выполнения этой программы?s := '123456789'; n := Pos ( '456', s); Delete ( s, n+2, 3 ); writeln ( s ); ответ: 10. Сколько единиц будет выведено на экран? s := '123456'; while Length(s) > 0 do beginDelete ( s, 1, 2 ); writeln ( '1' )end; ответ: 11. Программа должна считать, сколько раз в строке S встречается подстрока'12'. Какой оператор надо вставить вместо многоточия? Вводите ответ без пробелов. c := 0; repeat ... if p <> 0 then begin c := c + 1; Delete ( S, 1, p+1) end; until p = 0; ответ: 12. Программа должна считать, сколько раз в строкеSвстречается цифра'0'. Какой оператор надо вставить вместо многоточия? Вводите ответ без пробелов. c := 0; for k:=1 to Length(S) do begin if S[k] = '0' then ... end; ответ: 13. Какой оператор надо вставить вместо многоточия, чтобы в строке S были записаны символы строки Q в обратном порядке? Вводите ответ без пробелов. Q := '123456789'; S := '1'; for k:=2 to 9 do begin ... end; ответ:
ответ:Пиши в лс Объяснение: