Константин
?>

1.Напишите программу, в которой целочисленной переменной присваивается результат выполнения функции rand( Выведите значение переменной на экран.2.Напишите программу, которая будет выводить на экран 5 произвольных чисел из промежутка [0, 0001 до 1].3.Напишите программу, которая будет выводить на экран 3 произвольных числа из промежутка [-0, 2 до 20].4.Напишите программу, которая будет выводить на экран 3 произвольных числа из промежутка [3, 45 до 7, 25].Язык c++

Информатика

Ответы

zagadka27
DIM a AS SINGLE, b AS SINGLE, h AS SINGLE
DIM x AS SINGLE, y AS SINGLE
CLS
INPUT "Vvedite a,b,h: ", a, b, h
FOR x = a TO b STEP h
   y = 1 / 2 * LOG(x ^ 2) + 1 / x ^ 2 + 2 - 1 / 2 * LOG(2) / 3
   PRINT "x="; x, "y="; y
NEXT x
END

Тестовое решение:
Vvedite a,b,h: 2.7,8.4,0.5
x= 2.7        y= 3.014901
x= 3.2        y= 3.145283
x= 3.7        y= 3.265854
x= 4.2        y= 3.376249
x= 4.7        y= 3.477307
x= 5.2        y= 3.570116
x= 5.7        y= 3.65572
x= 6.2        y= 3.735039
x= 6.7        y= 3.80886
x= 7.2        y= 3.877846
x= 7.7        y= 3.942562
x= 8.2        y= 4.003482
Vadim443

#include <iostream>

#include <string>

using  namespace std;

int main()

{

string w;

int b;

string arr;

 

getline(cin,w);

cin>>b;

cin.ignore();

getline(cin,arr);

 

if(w == "szyfruj")

{

 for(int i=0; i<arr.size(); i++)

 {

  if(int(arr[i])>=97 &&  int(arr[i])<=122 || int(arr[i])>=65 && int(arr[i])<=90)

  {

   if(int(arr[i])>=97 &&  int(arr[i])<=122)

   {

    if(int(arr[i])+b>122) arr[i]-=26;

    arr[i]+=b;

   }

   else

   {

    if(int (arr[i])+b>90) arr[i]-=26;

    arr[i]+=b;

   }

  }

 }

}

if(w == "odszyfruj")

{

 for(int i=0; i<arr.size(); i++)

 {

  if(int(arr[i])>=97 &&  int(arr[i])<=122 || int(arr[i])>=65 && int(arr[i])<=90)

  {

   if(int(arr[i])>=97 &&  int(arr[i])<=122)

   {

    if(int(arr[i])-b<97) arr[i]+=26;

    arr[i]-=b;

   }

   else

   {

    if(int (arr[i])-b<65) arr[i]+=26;

    arr[i]-=b;

   }

  }

 }

}

cout<<arr;

return 0;

}

Объяснение:

код  на с++ для примера

пункт  со  сдвигом  букв сам  сделаешь  

P. S.  у меня на  5 они  сдвигаются,

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1.Напишите программу, в которой целочисленной переменной присваивается результат выполнения функции rand( Выведите значение переменной на экран.2.Напишите программу, которая будет выводить на экран 5 произвольных чисел из промежутка [0, 0001 до 1].3.Напишите программу, которая будет выводить на экран 3 произвольных числа из промежутка [-0, 2 до 20].4.Напишите программу, которая будет выводить на экран 3 произвольных числа из промежутка [3, 45 до 7, 25].Язык c++
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

oserdyuk41
s9152992722344
milleniumwood633
Yurevich1701
Татьяна_Полулях
Татьяна902
MikhailovnaAnastasiya
bondarev05071962
Хрулёва
ksenyabobrovich7214
dilovarnazarov1986
Nikolai172
benonika
Chistov9721209
KseniGum9