DmitrievnaVera
?>

Создать массив случайных чисел, размерностью четыре на четыре. Определить сколько раз встречается в нём число, хранящееся в ячейке [3, 3].

Информатика

Ответы

artemkolchanov24

Задан одномерный массив, состоящий из целых чисел. Определить, сколько раз каждая цифра встречается в заданном массиве.

2 Числа вводятся с клавиатуры до тех пор, пока не будет введён нуль.

Обозначим: Xi-число, введённое i-m, Xn-число, введённое последним (перед нулём). Написать программу для вычесления выражения.

germanleon

Стеганку не люблю, но явно надо работать с словами песни

+ Изображения (цезаря?) дают наводку на Cesar cipher.

Заготовка на Python3

a = """A lover spurned

A lesson learned

On love you’ve got

Your fingers burnt

Shed bitter tears

Now love has turned

The sweet revenge

Of a lover spurned

A passing phase

A week of love

But all at once

You had enough

It pales so soon

Waned with the moon

No deep concern

For a lover spurned

She’ll destroy you with her little games

See you swallow all the blame

Make you pay in many ways

For the pleasure of watching you squirm

She’ll tell her friends to treat you rough

That you just weren’t good enough

Make the going really tough

For the pleasure of watching you burn in hell

And every day

More guilt to pay

A lesson learned

From a lover spurned

It was all so cosy for you

You had a wife, two children

And a beautiful house

And me, well you wanted me

When it suited your needs

And now, now I have nothing

Just a handful of faded photographs

Nothing but a cold empty heart

But I’m not easily forgotten

I’ll appear when you least expect

To make you pay

You asked for it that way

She’ll come to get you with a knife

Write poison letters to your wife

Totally destroy your life

For the pleasure of watching you squirm

She’ll make a fool of you at work

Drag your name through the dirt

Make sure that it really hurts

For the pleasure of watching you burn in hell

A lover spurned

A lesson learned

On love you’ve got

Your fingers burnt

Shed bitter tears

Now love has turned

The sweet revenge

Of a lover spurned

The sweet revenge

Of a lover spurned

""".replace('\n',' ').split()

enc = "9 17 23 20 25 26 27 28 17 21 20 1 x 7 22 9 1e 14 25 18 22 2 11 1x 13 14 25 1 21 17 19 11 1x 10 20 15 6 4 10 24 15 12 18 25 25 26 10 11 19 18 20 25 19 1x 17 14 4 13 25 20 e 2 11 24 15 11 18 22 25 7 16 24 15 x x"

mes = ""

for i in enc.split():

   try:

       mes += a[int(i)] + " "

   except:

       mes += i

print(mes)

dushechkin2
Type Mass = array[1..50,1..50] of integer;

Procedure ABC(Var A:Mass; Var k,Min:integer);
Var
   i,j:integer;
Begin
Write('M = ');ReadLn(i);
Write('N = ');ReadLn(j);
For i:= 1 to i do
    Begin
    For j:= 1 to j do
        Begin
        A[i,j]:=random(21)-10;
        Write(A[i,j]:3,' ')
        End;
    WriteLn;
    End;
{Поиск минимума}
Min:=A[1,1];
For i:= 1 to i do
    For j:= 1 to j do
        if A[i,j]<Min then Min:=A[i,j];
{Подсчёт минимумов}
k:=0;
For i:= 1 to i do
    For j:= 1 to j do
        if A[i,j]=Min then k:=k+1;
End;
Var
   A,B,C,D:Mass;
   Max,kMin,Min:integer;
Begin
Randomize;
WriteLn('Массив A(M,N):');
ABC(A,kMin,Min);
WriteLn('Min(A) = ',Min);
WriteLn('kMin(A) = ',kMin);
Max:=kMin;
WriteLn;

WriteLn('Массив B(M,N):');
ABC(B,kMin,Min);
WriteLn('Min(B) = ',Min);
WriteLn('kMin(B) = ',kMin);
if Max<kMin then Max:=kMin;
WriteLn;

WriteLn('Массив C(M,N):');
ABC(C,kMin,Min);
WriteLn('Min(C) = ',Min);
WriteLn('kMin(C) = ',kMin);
if Max<kMin then Max:=kMin;
WriteLn;

WriteLn('Массив D(M,N):');
ABC(D,kMin,Min);
WriteLn('Min(D) = ',Min);
WriteLn('kMin(D) = ',kMin);
if Max<kMin then Max:=kMin;
WriteLn;
WriteLn('Max(kMin(A),kMin(B),kMin(C),kMin(D)) = ',Max);
End.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Создать массив случайных чисел, размерностью четыре на четыре. Определить сколько раз встречается в нём число, хранящееся в ячейке [3, 3].
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Olga1233
endyurans2ooo
konstantin0112
Марина
NatalyaAlekseevich1644
asvavdeeva
nadezhdasvirina
Sacharov84
infooem
avdoyan6621
danaya3005
artemiusst
Zelinskaya-Andrei
Винников724
nikdenly