olimov
?>

Задача : Все клетки шахматной доски пронумерованы от 1 до 64 так, что первая строка клеток имеет номера от 1 до 8, вторая - от 9 до 16 и т. д. Написать программу, которая на ввод номера клетки выводит номера всех клеток, имеющих с ней общую сторону.

Информатика

Ответы

cleopatra1959
Крутить это все в уме - чистое наказание. Проще было написать программу.

// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

type
  Pinnacle=record
    St:Stack<integer>;
    No:integer;
  constructor (n:integer);
  begin
    St:=new Stack<integer>;
    No:=n
  end;
end;
 
var
  MoveNo:integer;

procedure MoveDisk(s1,s2:Pinnacle);
begin
  if s1.St.Count>0 then begin
    MoveNo+=1;
    s2.St.Push(s1.St.Pop);
    Writeln(MoveNo:3,': №',s2.St.Peek,' ',s1.No,' -> ',s2.No)
    end
end;
   
procedure MovePinnacle(n:integer; s1,s2,s3:Pinnacle);
begin
  if n=0 then exit;
  MovePinnacle(n-1,s1,s3,s2);
  MoveDisk(s1,s2);
  MovePinnacle(n-1,s3,s2,s1);
end;

begin
  var n:=5;
  var p1:=new Pinnacle(1);
  var p2:=new Pinnacle(2);
  var p3:=new Pinnacle(3);
  Range(n,1,-1).ForEach(i->p2.St.Push(i));
  MoveNo:=0;
  MovePinnacle(n,p2,p3,p1);
end.

Результат работы
  1: №1 2 -> 3
  2: №2 2 -> 1
  3: №1 3 -> 1
  4: №3 2 -> 3
  5: №1 1 -> 2
  6: №2 1 -> 3
  7: №1 2 -> 3
  8: №4 2 -> 1
  9: №1 3 -> 1
 10: №2 3 -> 2
 11: №1 1 -> 2
 12: №3 3 -> 1
 13: №1 2 -> 3
 14: №2 2 -> 1
 15: №1 3 -> 1
 16: №5 2 -> 3
 17: №1 1 -> 2
 18: №2 1 -> 3
 19: №1 2 -> 3
 20: №3 1 -> 2
 21: №1 3 -> 1
 22: №2 3 -> 2
 23: №1 1 -> 2
 24: №4 1 -> 3
 25: №1 2 -> 3
 26: №2 2 -> 1
 27: №1 3 -> 1
 28: №3 2 -> 3
 29: №1 1 -> 2
 30: №2 1 -> 3
 31: №1 2 -> 3

Иллюстрация первых пяти шагов приведена во вложении.

Спро ханойские башни расписать порядок ходов для перекладывания 5 дисков со второго стержня на трети
Максим_Нина
Составим уравнение
87_{10}=ab2_n, \ a \in [1..n-1], \, b \in[0..n-1], \, a,b \in \mathbb N
Воспользуемся расширенной записью числа
87=an²+bn+2 → an²+bn-85=0
Известно, что если многочлен с целочисленными коэффициентами имеет хотя бы один вещественный корень, то он находится среди делителей свободного члена. Нас интересуют только натуральные делители, большие 2, поскольку n - основание системы счисления и в этой системе имеется цифра 2.
85 = 5 × 17. Число 17 не подходит, потому что 17>10 и двухзначное десятичное число в системе счисления с основанием, большим 10, не может иметь в записи больше двух знаков. Следовательно, n=5.

Для проверки переводим 87 в систему счисления по основанию 5.
87 / 5 = 17, остаток 2
17 / 5 = 3, остаток 2
3 / 5 = 0, остаток 3.
Выписываем остатки в обратном порядке: 322
87₁₀ = 322₅ - в числе три разряда и оно оканчивается двойкой.

ответ: N=5

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задача : Все клетки шахматной доски пронумерованы от 1 до 64 так, что первая строка клеток имеет номера от 1 до 8, вторая - от 9 до 16 и т. д. Написать программу, которая на ввод номера клетки выводит номера всех клеток, имеющих с ней общую сторону.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

PopovViktorovna
teya07
vikka30
Станислав Валерий1696
Rik200081490
Andrei_Mariya
s45983765471717
ii090758
mamanger
modno-trikotazh
fomindmity1
korj8
Pervosha
Savva1779
Shcherbinin KOLIChEVA