mnkrasnova
?>

Написать программу, которая из слова «информатика» получает и выводит на экран слово «марка». Подсказка к решению: Слова марка состоит из трех кусочков которые мы можем получить из слова «информатика»: ма, р, ка. Надо получит эти три части с команды copy и затем сложить их. ма – copy (a, 6, 2) (кусочек берем из слова а= «информатика», буква м стоит на 6 месте, в кусочке 2 буквы) Program slova; Var a, b: string; Begin a:=’информатика’; b:= copy (a, 6, 2) + copy (a, 5, 1) + copy (a, 10, 2); WriteLn (b); End.

Информатика

Ответы

Kaccak8778

По идеи, строки в Паскале являются одномерными массивами, легче просто присвоить второй строке символы из первой строки:

b:= a[6]+a[2] ...

stairov536

1. Wine

Название Wine расшифровывается как Wine Is Not an Emulator. Это своего рода прослойка между приложениями Windows и системой Linux. Он позволяет устанавливать и запускать многие популярные Windows-программы и работать с ними так, как будто это родные приложения Linux.

Чтобы установить Wine, воспользуйтесь соответствующей командой.

1. Ubuntu, Debian, Mint:

sudo dpkg --add-architecture i386

wget -nc https://dl.winehq.org/wine-builds/Release.key

sudo apt-key add Release.key

sudo add-apt-repository "deb https://dl.winehq.org/wine-builds/ubuntu/ artful main"

sudo apt-get update

sudo apt-get install --install-recommends winehq-stable

2. Fedora:

sudo dnf install winehq-stable

3. openSUSE:

sudo zypper install wine

4. Arch, Manjaro:

sudo pacman -S wine

Когда Wine установлен, откройте его через ваше меню приложений или с команды

winecfg

. При первом запуске Wine может попросить установить некоторые дополнительные пакеты — позвольте ему это сделать. После этого все Windows-программы формата EXE ассоциируются в системе с Wine.

Теперь скачайте установщик нужного вам приложения Windows, найдите папку с ним в вашем файловом менеджере и откройте файл. Либо введите команду

wine путь_к_приложению

.

Windows-приложение запустится и будет работать так же, как и всегда. Если вы открыли установочный файл, начнётся установка приложения — как в Windows. Если программа не требует установки, вы сможете начать работать с ней немедленно.

Не все приложения могут быть установлены и запущены в Wine, хотя количество поддерживаемых впечатляет. Полный список можно посмотреть здесь.

2. Winetricks

установить Windows-программы на Linux

Wine — неплохой инструмент, однако интерфейс у него оставляет желать лучшего. Если вы намучились с этой программой, но так и не добились результата, попробуйте Winetricks. У неё приятный графический интерфейс для установки и запуска Windows-приложений, в котором куда проще разобраться новичку.

Установить Winetricks можно так:

1. Ubuntu, Debian, Mint:

sudo apt-get install winetricks

2. Fedora:

sudo dnf install winetricks

3. openSUSE:

sudo zypper install winetricks

4. Arch, Manjaro:

sudo pacman -S winetricks

Winetricks позволяет установить различные версии Microsoft Office и Photoshop, плеер foobar2000 и множество других программ. Поддерживаются и такие популярные игры, как Call of Duty, Call of Duty 4, Call of Duty 5, Biohazard и Grand Theft Auto: Vice City. Некоторые программы загружаются автоматически, для других будет предложено вставить установочный носитель. И, естественно, вы можете открывать собственноручно скачанные файлы формата EXE.

3. PlayOnLinux

установить Windows-программы на Linux

PlayOnLinux — ещё один удобный инструмент для запуска Windows-приложений в Linux. Как и Winetricks, он обладает простым графическим интерфейсом. Но, в отличие от него, PlayOnLinux позволяет вам выбирать конкретную версию Wine для того или иного приложения. Это полезно, если какая-то из нужных вам программ некорректно работает с новыми версиями Wine. В целом PlayOnLinux выглядит куда симпатичнее и практичнее, чем Winetricks.

Чтобы установить PlayOnLinux, выполните в терминале одну из следующих команд:

1. Ubuntu, Debian, Mint:

sudo apt-get install playonlinux

2. Fedora:

sudo dnf install playonlinux

3. OpenSUSE:

sudo zypper install playonlinux

4. Arch, Manjaro:

sudo pacman -S playonlinux

В меню установки PlayOnLinux можно найти множество предварительно сконфигурированных приложений и игр, которые вы можете загрузить и установить парой щелчков. Кроме того, PlayOnLinux можно скармливать собственные EXE-установщики. Приложение заботливо выберет за вас версию Wine и создаст значок установленной программы на рабочем столе.

4. Crossover

установить Windows-программы на Linux

Изредка бесплатные PlayOnLinux и Winetricks не справляются с установкой какого-нибудь особенно привередливого приложения. В таком случае вам может Crossover. Эта программа очень проста в использовании. Вам достаточно указать, какое приложение вы хотите установить, и подсунуть Crossover установочный файл. Всё остальное будет сделано за вас.

Лицензия Crossover на год стоит 39,95 доллара, но у программы есть и бесплатная пробная версия. Рекомендуется сначала установить необходимое вам приложение в ней, чтобы убедиться, что оно работает корректно.

Crossover →

Объяснение:

взято с сайта :

https://lifehacker.ru/programmy-windows-na-linux/

nuralievelsh

import math

import sys

#Задача 1

print("Програма, яка визначає квадратний корінь числа")

a = int(input("Введіть ціле число: "))

if a == 0:

   sys.exit(0)

b = math.sqrt(a)

print("Квадратний корінь з числа", a, "дорівнює", b)

#Задача 2

print("\nПрограма, яка визначає площу круга")

c = int(input("Введіть дійсне число - радіус кола: "))

if c == 0:

   sys.exit(0)

d = math.pi*c**2

print("Площа круга дорівнює", d)

#Задача 7

print("\nПрограма, яка визначає площу круга")

c = int(input("Введіть дійсне число - діаметр кола: "))

if c == 0:

   sys.exit(0)

d = math.pow(c, 2) // 4 * math.pi

print("Площа круга дорівнює", d)

#Задача 8

print("\nПрограма, яка обчислює довжину гіпотенузи прямокутного трикутника")

c1 = int(input("Введіть перший катет: "))

c2 = int(input("Введіть другий катет: "))

if c1 == 0 or c2 == 0:

   sys.exit(0)

h = math.hypot(c1, c2)

print("Довжина гіпотенузи прямокутного трикутника дорівнює", h)

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая из слова «информатика» получает и выводит на экран слово «марка». Подсказка к решению: Слова марка состоит из трех кусочков которые мы можем получить из слова «информатика»: ма, р, ка. Надо получит эти три части с команды copy и затем сложить их. ма – copy (a, 6, 2) (кусочек берем из слова а= «информатика», буква м стоит на 6 месте, в кусочке 2 буквы) Program slova; Var a, b: string; Begin a:=’информатика’; b:= copy (a, 6, 2) + copy (a, 5, 1) + copy (a, 10, 2); WriteLn (b); End.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

YuREVICh646
varvv15
vasavto1
Татьяна902
tomogradandrey
domtorgvl20082841
oksana77768
Yurevich1291
vanvangog199826
nnbeyo
alyonafialka
mstapottery
zolotayaoxana1982
petrovichvit2933
tanu0618
▲