olimov
?>

Напишите программу вычисляющую значение функции. в КуМиреY=-1 при х<0 0 при х=0 1 при х>0 ​

Информатика

Ответы

Татьяна
//Pascal
  var a,b, I, maxsumm, max : integer;
 
  function summdel(x:integer):integer; //результат - сумма делителей х
  var k,sum:integer;
  begin
    sum:=0;
    for k := 1 to x div 2 + 1 do
      if x mod k = 0 then sum:= sum+k;
    summdel:=sum;
  end;
 
  begin
   writeln('Введите границы a,b ');
   readln(a,b);
    maxsumm := 1;
    max := 1;
    for i := a to b do
     begin
        if summdel(i) > maxsumm then
          begin maxsumm:= summdel(i);
            max := i;
          end;
     end;
     writeLn('Максимальная сумма делителей - ', maxsumm, ' число - ',max)
  end.
Dom540703174
ответ: да можно ,
Для каждого груза можешь привести 
Данный груз +   некая гиря     =  противовес 
1                     +     0                   = 1
2                     +     1                   = 3
3                     +     0                   = 3
4                     +     0                   = 3+1
5                     +     3+1               = 9
6                     +     3                   = 9
7                     +     3                   = 9+1
8                     +     1                   = 9 
9                     +     0                   = 9
10                   +     0                   = 9+1
11                   +     1                   = 9+3
12                   +     0                   = 9+3
13                   +     0                   = 9+3+1

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу вычисляющую значение функции. в КуМиреY=-1 при х<0 0 при х=0 1 при х>0 ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ver2bit29
krutikovas
poiskmarina
dmitrij-sp7
blackpoint2020273
asvavdeeva
savva-vika
alexk13
zipylin
taanaami75
mary---jane49
Pona4ka93
aivia29
valera850515
skzzkt