sales5947
?>

Составьте программу для нахождения суммы денег, которую мальчик заработает от продажи B газет, если он зарабатывает А р. На продаже каждой газеты. Количество газет и цена газеты вводятся с клавиатуры. Паскаль.

Информатика

Ответы

arbekova

Во вложении.

Объяснение:


Составьте программу для нахождения суммы денег, которую мальчик заработает от продажи B газет, если
Larya
Программа ищет и выводит все трехбуквенные слова, содержащие русские и/или латинские буквы в обоих регистрах. Слова могут разделяться любым количеством любых символов, кроме символа подчеркивания.

// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('Вводите:');
  var m:=s.Matches('\b\w{3}\b');
  if m.Count>0 then m.Println
  else Writeln('Нет трехбуквенных слов')
end.

Пример:
Вводите: Как найти все слова, где букв - три?
Как все где три
sharikplushelen
Var s,tmp:string;
     i,n:integer;
     flag,word:boolean;
function letter (const let:char):boolean;
 begin
   if ((let>='a') and (let<='z')) or ((let>='A') and (let<='Z')) then letter:=true
     else letter:=false;
 end;
begin
  readln (s);
  s:=s+' ';
  n:=length(s);
  flag:=false;
  for i:=1 to n do
   begin
     if (letter(s[i])) and (not flag) then
      begin 
        flag:=true;
        tmp:='';
        word:=false;
      end else if (not letter(s[i])) and (flag) then
      begin 
       flag:=false;
       if (word) and (not (tmp='')) then writeln (tmp);
      end;
     if (flag) then
      begin 
        tmp:=tmp+s[i];
        if (s[i]='k') then word:=true;
      end; 
   end;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу для нахождения суммы денег, которую мальчик заработает от продажи B газет, если он зарабатывает А р. На продаже каждой газеты. Количество газет и цена газеты вводятся с клавиатуры. Паскаль.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

oyudina
sv-rud
baeva-larisa8165
shumilovs7252
Nadirovich1317
Stanislavovna1237
eidevyatkina
Спиридонова
Вячеславович-Дмитрий1694
Bella
egoryandiana3727283
drozd228758
Александрович Владимирович
appbiznessm
yliana