evrotrastop64
?>

1.Решить, используя цикл repeat Напишите программу, которая в последовательности целых чисел определяет сумму отрицательных нечетных чисел. Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0. (0 – признак окончания ввода, не входит в последовательность чисел Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30 000. Программа должна вывести одно число: сумму отрицательных нечетных чисел. 2. Решить, используя цикл While Напишите программу, которая в последовательности целых чисел определяет значение наибольшего числа из всех кратных 6 введенных чисел. Программа получает на вход целые положительные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0. (0 – признак окончания ввода, не входит в последовательность чисел). Количество чисел не превышает 1000. Введенные числа не превосходят 30 000. Среди введенных чисел есть хотя бы одно нечетное число Программа должна вывести одно число: наибольшее из всех нечетных введенных чисел. 3. Решить, используя цикл While Напишите программу, которая в последовательности целых чисел определяет количество отрицательных чисел кратных 9. Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0. (0 – признак окончания ввода, не входит в последовательность чисел). Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30 000. Программа должна вывести одно число: количество отрицательных чисел, кратных

Информатика

Ответы

aci2003

Cigcgi9fy9uf9yfyc9gypsy7xgdgig chxohoxh jcppohccc7g 7fuc g7c7 hfy7 hcg7 yv7fyucgct7c vh7vy8gucg8gyy7c7ct7c68hch8u7cgcy7c78hc9hvgu09hv8hch

pak1998378
Обозначим P,Q,A утверждение что х принадлежит соответствующему отрезку
¬А отрицание А, то есть х не принадлежит А
перепишем и упростим исходную формулу
P→((Q∧¬A)→P)
известно что X→Y=¬X∨Y (доказывается просто, например через таблицу истинности)
тогда:
P→(¬(Q∧¬A)∨P)
раскроем скобку ¬(Q∧¬A) с закона де Моргана (стыдно их не знать, если что это такие же основы как и таблицы истинности)
P→(¬Q∨¬¬A∨P) = P→(¬Q∨A∨P) = ¬P∨¬Q∨A∨P
¬P∨P=1 то есть всегда истинно и 1∨Х=Х значит ¬P и P можно убрать
остается ¬Q∨A
Значит х либо принадлежит А либо не принадлежит Q
для выполнения этого условия необходимо чтобы все значения Q принадлежали А, тогда минимальное А совпадает с Q
ответ А=[40,77]
marinanx
Ll - long long

dp[i] = dp[i-1] + dp[i-2] + dp[i-5] + dp[i-10];
ll dp[666];
dp[0] = 1;
for(int i=0;i<=64;i++)
{
dp[i+1]+=dp[i];
dp[i+2]+=dp[i];
dp[i+5]+=dp[i];
dp[i+10]+=dp[i];
cout << i << ": " << dp[i] << endl;
}
это если порядок важен, то есть 2 + 1 != 1 + 2, тогда ответ
489475342266653, наверное
а иначе 644

ll ans=0;
for(int i=0;i<10;i++) // 10
{
for(int j=0;j<20;j++) // 5
{
for(int k=0;k<50;k++) // 2
{
ll now = i*10 + j*5 + k*2;
if(now<=64) ans++;
}
}
}
cout << ans;

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1.Решить, используя цикл repeat Напишите программу, которая в последовательности целых чисел определяет сумму отрицательных нечетных чисел. Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0. (0 – признак окончания ввода, не входит в последовательность чисел Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30 000. Программа должна вывести одно число: сумму отрицательных нечетных чисел. 2. Решить, используя цикл While Напишите программу, которая в последовательности целых чисел определяет значение наибольшего числа из всех кратных 6 введенных чисел. Программа получает на вход целые положительные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0. (0 – признак окончания ввода, не входит в последовательность чисел). Количество чисел не превышает 1000. Введенные числа не превосходят 30 000. Среди введенных чисел есть хотя бы одно нечетное число Программа должна вывести одно число: наибольшее из всех нечетных введенных чисел. 3. Решить, используя цикл While Напишите программу, которая в последовательности целых чисел определяет количество отрицательных чисел кратных 9. Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0. (0 – признак окончания ввода, не входит в последовательность чисел). Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30 000. Программа должна вывести одно число: количество отрицательных чисел, кратных
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

MikhailovichKrizhnaya578
Anzhelika-Bulanov802
horst58
skvik71672
ams-sim
Telenkovav
ЕкатеринаРустам
Информатика 8 класс задание 3
tenvalerij
Попова1271
konstantinslivkov
samuilik-v
format-l3364
farmprofi
oksit
bezpalova2013