Ofelya1308
?>

Составить программу для решения задачи. Даны число, натуральные числа a и n. Вычислить: сумму всех натуральных чисел больших а и не превосходящих n Задачу запишите в окошко, либо прикрепите скриншот с паскаля.

Информатика

Ответы

arina2403423
Const   N = 7;Var   A:array[1..N,1..N] of integer;   i,j:integer;BeginFor i:= 1 to N do    Begin    For j:= 1 to N do        Begin        A[i,j]:=random(21)-10;        Write(A[i,j]:3,' ')        End;    WriteLn    End;WriteLn;For i:= 1 to N div 2+(N mod 2) do    Begin    For j:= 1 to N do        Begin        if (j<=N div 2+i)and(N div 2-i+(N mod 2)<j) then A[i,j]:=99;        Write(A[i,j]:3,' ')        End;    WriteLn;    End;For i:= (N div 2)+(N mod 2)+1 to N do    Begin    For j:= 1 to N do        Begin        if (i-N div 2-1<j)and(j<=N+N div 2+1-i) then A[i,j]:=99;        Write(A[i,j]:3,' ')        End;    WriteLn;    End;End.
pavlovm8316
Константы в Pascal.
Иногда, бывает так, что у нас в программе встречаются величины, которые не меняются в процессе выполнения программы (т.е. фактически они противоположность переменных). Такие величины называются константами. Константы указываются в специальном ...
Функции Pred, Succ в Pascal.
В данном уроке мы рассмотрим функции, применяемые к типу CHAR. Функция Pred возвращает в качестве значения предшествующий символ, а функция Succ возвращает последующий символ.
Использование Var, Integer, Readln.
Процедура Readln используется не только для задержки экрана. Ее основная задача - ввод данных с клавиатуры. В этой статье мы научимся вводить числа с клавиатуры, и потом выводить их на экран. Для этого нам будет необходимо познакомиться с разделом ...

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу для решения задачи. Даны число, натуральные числа a и n. Вычислить: сумму всех натуральных чисел больших а и не превосходящих n Задачу запишите в окошко, либо прикрепите скриншот с паскаля.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

VladimirovnaBugrova
Arutyunovich
tatyanaryzhkova
kristi-a-90
Kozloff-ra20146795
Алена-Петрова285
Anatolevich
moskvabelarus
gulsinatahckeeva
bolosolo77
Chikichev456
Irina-Tunyan
nyuraborova89
whiskyandcola
zsa100
▲