dima-pashkovec
?>

Изучите блок-схему и напишите программу на языке С++ в среде Code Blocks #include using namespace std; int main () {int ответ , ответ ; S = ответ ; for (i=ответ ; ответ <=ответ ; i+=ответ ) { S=ответ ; } cout << "S= " << ответ ; return 0; } Рассчитайте и укажите какое получится значение S = ответ Исправьте фрагменты программы, содержащие пустые окна на соответствующий код для получения результата решения данной задачи. Для ответов воспользуйтесь следующими словами и данными, вписав их в пустые окна ответов (величина рассчитанного значения S не указана): S (использовать 3 раза) i (использовать 3 раза) 0 (использовать 2 раза) 2 (использовать 1 раз) 20 (использовать 1 раз) + (использовать 1 раз)

Информатика

Ответы

katekn6032

Рассмотрим решение

Объяснение:

Итак, задача состоит в том, чтобы переставить слова, разделенные пробелом, этим и будем пользоваться.

На вход получим строку s, где слова разделены пробелом. Запишем все слова, разделенные пробелом, в список lis_s с list comprehensions.

В список rub запишем все элементы из списка lis_s в обратном порядке - в этом нам уменьшающийся range (шаг -1).

Так как требуется строка, а не список, то введем новую строку new_string, которая и будет являться результатом.  В цикле for будем прибавлять к ней каждый элемент списка rub. Однако мы столкнемся с некоторой проблемой: слова не будут разделены. Тогда будем добавлять пробелы после каждого слова. Но и здесь ждет подвох: так мы добавим пробел и после последнего слова, тем самым изменив длину данной нам сначала строки. Выход: введем переменную bad_count, в каждой итерации цикла for будем прибавлять к ней 1, пока значение bad_count не совпадет с длиной списка rub. Как только это случится, пробел мы не прибавим.

Подробное решение приведено на скриншоте.


Составить программу, которая изменяет последовательность слов в строке на обратную. ПИТОН НАПРИМЕР в
Леонтьева

const n=5;

procedure Swap(var a,b:integer);

var tmp:integer;

begin

tmp:=a;

a:=b;

b:=tmp;

end;

var a:array[0..n-1,0..n-1] of integer;

   i,j,k:byte;

   x:integer;

begin

writeln('Исходная матрица:');

for i:=0 to n-1 do

begin

 for j:=0 to n-1 do

  begin

   read(a[i][j]);

  end;

end;

for i:=0 to n-1 do

begin

 for j:=0 to n-1 do

  begin

   write(a[i,j]:3);

  end;

 writeln;

end;

//сортировка всей матрицы по возрастанию

for i:=0 to n*n-2 do

for j:=i+1 to n*n-1 do

if a[i div n,i mod n]>a[j div n,j mod n]

then Swap(a[i div n,i mod n],a[j div n,j mod n]);

writeln('Отсортированная матрица по возрастанию');

for i:=0 to n-1 do

begin

 for j:=0 to n-1 do

 write(a[i,j]:3);

 writeln;

end;

end.

// РЕШЕНИЕ ЗАДАЧ Telegram: @Vadukk

Объяснение:


ПАСКАЛЬ. Создать двумерный массив, ввести с клавиатуры значения и отсортировать их в порядке возраст

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Изучите блок-схему и напишите программу на языке С++ в среде Code Blocks #include using namespace std; int main () {int ответ , ответ ; S = ответ ; for (i=ответ ; ответ <=ответ ; i+=ответ ) { S=ответ ; } cout << "S= " << ответ ; return 0; } Рассчитайте и укажите какое получится значение S = ответ Исправьте фрагменты программы, содержащие пустые окна на соответствующий код для получения результата решения данной задачи. Для ответов воспользуйтесь следующими словами и данными, вписав их в пустые окна ответов (величина рассчитанного значения S не указана): S (использовать 3 раза) i (использовать 3 раза) 0 (использовать 2 раза) 2 (использовать 1 раз) 20 (использовать 1 раз) + (использовать 1 раз)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ovdei71
ksoboleva
agaloan8
Irinalobanowa
kriapex
Смирнов-Оськина
СмыковаДарья1969
bulenbeiser
ПодлеснаяМакарова1883
федороа
Sergei_Olga658
mlf26
smnra219
sryzhova6392
Палкина-Дроздова