Надья-Олеговна
?>

очень Ветвление в языке Паскаль. Начертите схему алгоритма и напишите программу для ответа на во пройдет ли трактор массой m кг по льду, выдерживающему давление Па, если площадь ее гусениц равна S м2? Примечание. Трактор пройдет по льду, если давление р, создаваемое трактором будет меньше Па .Формула для расчета давления p=F/S, где F=mg, а g=9, 8 м/с2 .

Информатика

Ответы

Anshel2018534
1. Современное решение

// PascalABC.NET 3.2, сборка 1488 от 21.06.2017
// Внимание! Если программа не работает, обновите версию!

function From5to10(Self:sequence of string):sequence of integer;
    extensionmethod;
// Перевод последовательности заданных на строках пятиричных чисел
// в последовательность целых десятичных чисел
begin
  foreach var s in Self do begin
    var r:=0;
    var pa:=1;
    foreach var c in s.Reverse do begin
      r+=c.ToDigit*pa; pa*=5
    end;
    yield r
    end
end;

begin
  var s:=ReadlnString('Введите строку:').MatchValues('[0-4]+').From5To10;
  if s.Count=0 then Writeln('S=-1')
  else Writeln('S=',s.Sum)
end.

Пример
Введите строку: sdf812973j223k
S=73

2. Решение на TurboPascal ("Так писали наши отцы и деды в 1983 году, так и нас сейчас учат в школе")

uses Crt;

function From5to10(n:string):integer;
{ Перевод из пятиричного числа в строковом представлении
  в целое десятичное }
var
  i,pa,s:integer;
begin
  s:=0;
  pa:=1;
  for i:=Length(n) downto 1 do begin
    s:=s+pa*(Ord(n[i])-Ord('0'));
    pa:=pa*5
    end;
  From5to10:=s
end;

var
  s,w:string;
  i,k,r:integer;
begin
  ClrScr;
  Write('Введите строку: ');
  Readln(s);
  w:='';
  r:=0;
  k:=0;
  for i:=1 to Length(s) do begin
    if Pos(s[i],'01234')>0 then begin
      if w='' then k:=k+1;
      w:=w+s[i]
      end
    else
      if w<>'' then begin
        r:=r+From5to10(w);
        w:=''
        end
    end;
  if k=0 then Writeln('S=-1')
  else Writeln('S=',r);
  ReadKey
end.
puma802
Программа приложена файлом для Visual Basic for Applications

Ниже текст этой программы продублирован

Sub trans_sequence(ByVal M)'заполнение массива и создание преобразованной последовательности чисел  N = M  Dim mas()  ReDim mas(M)  Sg = ""  Sf = ""  Randomize  For i = 1 To M    mas(i) = Round((Rnd(100) - 0.5) * 100)    Sg = Sg + Str(mas(i))    If (mas(i) < 0) Then mas(i) = mas(i) * mas(i)    Sf = Sf + Str(mas(i))    If i <> M Then           Sg = Sg + ","       Sf = Sf + ","    End If  Next i        MsgBox "последовательность чисел " + Sg + Chr(10) + "преобразованная последовательность " + SfEnd Sub

Sub test()  trans_sequence (25)End Sub

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

очень Ветвление в языке Паскаль. Начертите схему алгоритма и напишите программу для ответа на во пройдет ли трактор массой m кг по льду, выдерживающему давление Па, если площадь ее гусениц равна S м2? Примечание. Трактор пройдет по льду, если давление р, создаваемое трактором будет меньше Па .Формула для расчета давления p=F/S, где F=mg, а g=9, 8 м/с2 .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Tatianarogozina1306
nkochladze
kormilitsynarita
avto3132
osipov1984osipov
Marinanagornyak
d43irina
борисовна Елена78
kuchino09
Vyacheslavovich1431
Gennadevich Aleksandr
Morozova-Starikov
elaginaelena70
Владимир
valentinakarma2800