frolevgevg6420
?>

Умоляю У вас есть персонаж, обладающий рядом и статов. Напишите программу по заданным условиям: 1. Персонаж имеет набор статов: strength, dexterity, intelligence, wisdom, charisma. Каждая стата имеет свой запас. Домашнее задание № 9 2 Значения запасов каждой статы должны быть случайны – в пределах от 60 до 80 и быть представлены в списке stats = []: В начале игры пользователю предоставляется возможность однократно повысить одну стату на случайное количество единиц – от 5 до 15: Обратите внимание, что повышая одну стату на сгенерированное число, все остальные должны уменьшиться на случайное значение в пределах от 5 до 15: Персонаж обладает набором скилов: fireball, lightning, silence, fire ward. Использование каждого из них отнимает разное количество единиц статов, а именно: Занесите эти данные в список, чтобы в дальнейшем воспользоваться ими в игре: Предоставьте пользователю возможность использовать скилы, например, по нажатию f применяется Fireball, l – Lightning и т. д. После применения какой-либо из запас статов будет уменьшаться, согласно приведенной выше таблице. Рассмотрим следующий пример: 1. Было Stats: 70 64 63 80 65. 2. Применили Fireball: 12 15 28 10 5. 3. Стало Stats: 58 49 35 70 60. Следите за тем, чтобы элементы в списке stats = [] не стали отрицательными. Результат работы: файл с расширением .py. Выбор ПО на ваше усмотрение: Atom, PyCharm, Python IDLE или др решить даный во

Информатика

Ответы

Lerkinm
Const
 n = 20;

var
 pos,neg: integer;
 i,k,x: integer;
 ev,un: integer;
 a,b: array [1..n] of integer;

begin
 for i := 1 to n do
   read(a[i]);
  k := 0;
 pos := 0;
 neg := 0;
  for i := 1 to n do
   begin
      ev := 0;
   un := 0;
      x := a[i];
      if x <> 0 then
     if x > 0 then
       if (x < pos) or (pos = 0) then
         pos := x
       else
     else
       if (x > neg) or (neg = 0) then
         neg := x;
      x := abs(x);
      while x <> 0 do
     begin
     if odd(x) then
       un := un + 1
     else
       ev := ev + 1;
     x := x div 10
     end;
      if un = ev then
     begin
     k := k + 1;
     b[k] := a[i]
     end
      end;

 writeln(pos,' ',neg);
 for i := 1 to k do
   write(b[i],' ')
 end.
partners
2) Все записи в базе данных имеют:
Если здесь вопрос понимать "Все записи в таблице реляционной БД имеют", то ответ, скорее всего, 
d) Одинаковое количество полей

3) Укажите правильную последовательность действий при работе с базами данных (составить последовательность из букв):
c) Продумать структуру базы данных 
d) Дать имя каждому полю в базе данных
a) Занести данные в таблицу
b) Осуществить сортировку записей в базе данных

4) Поиск информации– это:
a) выбор информации по определённым правилам

5) Примером базы данных может служить:
Скорее всего
b) Телефонный справочник,
хотя и 
c) Энциклопедия тоже может быть

6) В каком из перечисленных типов полей, данные могут выглядеть таким образом: 
Да или Нет ?
b) В логическом поле

7) В какой из перечисленных пар данные относятся к одному типу?
a) 12.04.98 и 01/02/99;  - тип дата
b) ДА и TRUE (ИСТИНА);  - логический тип

8) База Данных содержит информацию о каждой собаке из клуба собаководства: кличка, порода, дата рождения, пол, количестве медалей. Какого типа должны быть поля?
d) текстовое, текстовое, дата, текстовое, числовое;

Возможно, такие ответы. Хотя многие вопросы некорректны.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Умоляю У вас есть персонаж, обладающий рядом и статов. Напишите программу по заданным условиям: 1. Персонаж имеет набор статов: strength, dexterity, intelligence, wisdom, charisma. Каждая стата имеет свой запас. Домашнее задание № 9 2 Значения запасов каждой статы должны быть случайны – в пределах от 60 до 80 и быть представлены в списке stats = []: В начале игры пользователю предоставляется возможность однократно повысить одну стату на случайное количество единиц – от 5 до 15: Обратите внимание, что повышая одну стату на сгенерированное число, все остальные должны уменьшиться на случайное значение в пределах от 5 до 15: Персонаж обладает набором скилов: fireball, lightning, silence, fire ward. Использование каждого из них отнимает разное количество единиц статов, а именно: Занесите эти данные в список, чтобы в дальнейшем воспользоваться ими в игре: Предоставьте пользователю возможность использовать скилы, например, по нажатию f применяется Fireball, l – Lightning и т. д. После применения какой-либо из запас статов будет уменьшаться, согласно приведенной выше таблице. Рассмотрим следующий пример: 1. Было Stats: 70 64 63 80 65. 2. Применили Fireball: 12 15 28 10 5. 3. Стало Stats: 58 49 35 70 60. Следите за тем, чтобы элементы в списке stats = [] не стали отрицательными. Результат работы: файл с расширением .py. Выбор ПО на ваше усмотрение: Atom, PyCharm, Python IDLE или др решить даный во
Ваше имя (никнейм)*
Email*
Комментарий*