Давид-Александр
?>

Составить программу, позволяющую с датчика случайных чисел сформировать матрицу размерностью N. Определить:минимальный элемент, лежащий ниже побочной диагонали;произведение ненулевых элементов последней строки. pascal abc​

Информатика

Ответы

Georgievna1407
//PascalABC.NET 3.1 сборка 1239
const
    n = 10;
    m = 10;

var
    i, j: integer;
    a, b: array[1..n, 1..m] of integer;
    f: boolean;

begin
    for i := 1 to n do
    begin
        for j := 1 to m do
        begin
            a[i, j] := random(50);
            write(a[i, j]:3, ' ');
        end;
        writeln;
    end;
    writeln;
    
    for i := 1 to n do
    begin
        f := false;
        for j := 1 to m do
        begin
            if not f and (a[i, j] mod 2 = 1) then begin
                a[i, j] := 2 * a[i, j];
                f := true;
            end;
            write(a[i, j]:3, ' ');
        end;
        writeln;
    end;
end.
Vladimirovich-Aleksandrovna96

#include <iostream>

#include <vector>

using namespace std;

// глобальные переменные

const int arraySize = 10;

vector <int> numbers;

// сам алгоритм.

void result(){

   

 // совет - обьявляй все переменные в начале функции  

 int leader = 0;

 

 int maxCount = 0;

 int count = 0;

 

 

 // поиск самого частого числа

 for (int c = 0; c < 9;c++){

     // обнуляем счетчик

     count = 0;

     

     for (int c1 = 0;c1 < arraySize;c1++){

         if (numbers[c1] == c) count++;

     }

     

     // проверка на лидера

     if (maxCount < count){

         leader = c;

         maxCount = count;

     }

 }

 

 

 // ну..с посмотрим:

 cout << "Leader: " << leader << " (" << maxCount << ") " << std::endl;

}

int main()

{

   // подготовка масива

   srand(time(NULL)); // обнулем внутрений таймер для полного рандома

   for (int c = 0; c < arraySize;c++) {

       numbers.push_back(rand() % 9); // заполняем масив числами

   }

   // посмотрим на оригинальный масив

   cout << "Original array: ";

   for (int c = 0;c < arraySize;c++) cout << numbers[c] << " ";

   cout << std::endl;

   // сортировка

   result();

   return 0;

}

Объяснение:

Хорошая книга по с++: Герберт Шилд - с++ базовый курс.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, позволяющую с датчика случайных чисел сформировать матрицу размерностью N. Определить:минимальный элемент, лежащий ниже побочной диагонали;произведение ненулевых элементов последней строки. pascal abc​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

НиколаевнаФ
andreyshulgin835
AOS2015
sergeev-alp5
Strelkov-Roman1263
vasilevich-F
dkvsadovoe
mnkrasnova
vsnimschikov391
ГармаеваЕкатерина1637
tanyatanyat
mbobo28311
kuharhuks
suturinavaleriya51
rusplatok