Александровна
?>

нужно сделать 3 задачи1) Написать задачу: Обмен переменных значениями. (Пример: было: а=7, b= 2, стало:а=2, b= 7) Числа вы вводите с клавиатуры. 2)Напишите программу, которая получает с клавиатуры четырёхзначное натуральное число и переставляет его первую и последнюю цифры, например, из числа 1234 должно получиться число 4231. 3) Напишите программу, которая получает с клавиатуры два целых числа, а и b (a < b), и выводит на экран 5 случайных целых чисел на отрезке [a; b].​

Информатика

Ответы

tochkamail7

Меньше чем 3-х основание СС быть не может. (Сама догадайся почему ;-)  

 

Делим:  

 

23 : 3 = 7 ост. 2 — подходит  

23 : 4 = 5 ост. 3 — не подходит  

23 : 5 = 4 ост. 3 — не подходит  

23 : 6 = 3 ост. 5 — не подходит  

23 : 7 = 3 ост. 2 — подходит  

23 : 8 = 2 ост. 7 — не подходит  

23 : 9 = 2 ост. 5 — не подходит  

23 : 10 = 2 ост. 3 — не подходит  

23 : 11 = 2 ост. 1 — не подходит  

23 : 12 = 1 ост. 11 — не подходит  

23 : 13 = 1 ост. 10 — не подходит  

23 : 14 = 1 ост. 9 — не подходит  

23 : 15 = 1 ост. 8 — не подходит  

23 : 16 = 1 ост. 7 — не подходит  

23 : 17 = 1 ост. 6 — не подходит  

23 : 18 = 1 ост. 5 — не подходит  

23 : 19 = 1 ост. 4 — не подходит  

23 : 20 = 1 ост. 3 — не подходит  

23 : 21 = 1 ост. 2 — подходит  

23 : 22 = 1 ост. 1 — не подходит  

23 : 23 = 1 ост. 0 — не подходит  

 

Далее для всех СС больше 23 остаток будет 23. Следовательно нет смысла их рассматривать.  

 

Итого: 2, 7 и 21.

morsh9345

"...напечатает сначала 2, потом - 6" -- это значит a=2 и b=6?


про пятеричные записи ничего не понял...  :) И ИМХО к чему такие сложности? И для чего нам комп и программа? Я подправил исходную прогу чтобы она выдавала все числа подходящие по условию

var x,a,b: longint;


begin

   for var i := 999 DownTo 100 do begin

       a := 0;

       b := 1;

       x := i;

       while x>0 do begin

           if x mod 2 > 0 then a := a+1 else b := b+(x mod 5);

           x := x div 5;

       end;

       if (a = 2) and (b = 6) then writeln('x = ', i, ' a = ', a, ' b = ',b);

   end;

end.


прога проводит расчет для всх трехзначных чисел от 999 до 100

итого мы видим что максимальное подходящее число это 960

при необходимости прогу можно переделать чтобы она находила только максимальное число.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

нужно сделать 3 задачи1) Написать задачу: Обмен переменных значениями. (Пример: было: а=7, b= 2, стало:а=2, b= 7) Числа вы вводите с клавиатуры. 2)Напишите программу, которая получает с клавиатуры четырёхзначное натуральное число и переставляет его первую и последнюю цифры, например, из числа 1234 должно получиться число 4231. 3) Напишите программу, которая получает с клавиатуры два целых числа, а и b (a < b), и выводит на экран 5 случайных целых чисел на отрезке [a; b].​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

lsyrbu
klepa-79
aananasAnastiya1270
kirill76536
yusinelnik8
arteevdimon
grachevakaterina
Николаевна Филиппов1936
elenasnikitina84
magnit-expo
margo929
papanovar
melnik-738
olelukoya4
e90969692976