mmreznichenko
?>

решить задание по информатике. Массив А из 4 элементов заполняется по формуле. Установите соответствие между формулой и полученным массивом. for x:=1 to 4 do A[x]:=3*x+1; A: 4, 7, 10, 13 for x:=1 to 4 do A[x]:=x*(x+1); A: 2, 5, 8, 11 for x:=1 to 4 do A[x]:=3*x-1; A: 0, 3, 6, 9 for x:=1 to 4 do A[x]:=3*(x-1); A: 2, 6, 12, 20

Информатика

Ответы

ekatef45

Объяснение:Var

    a: array[1..10] of integer;

    i: integer;

begin

    for i:=1 to 10 do

         a[i] := i-4;

    a[2] := a[9] + a[2];

    a[9] := a[2] - a[9];

    a[2] := a[2] - a[9];

    for i:=1 to 10 do

         write(a[i], );

end.

Feyruz90
Граф - множество вершин и ребер, соединяющих эти вершины.
Он несет информацию об элементах системы и связи между ними.
Элементы системы изображаются как вершины или узлы графа.
Отношения между ними изображаются как ребра или дуги графа.
Деревом называют ациклический (то есть между любыми вершинами есть только один путь), связный (то есть от любой вершины графа можно добраться в другую) граф.
Корень дерева - это вершина с нулевой степенью захода (то есть в нее не ведут другие ребра). Для неориентированного графа это просто выбранная нами вершина.
Ветви - это ребра дерева.
Листья дерева - это вершины с нулевой степенью исхода (то есть из них не выходят ребра), т.е. не имеющих поддеревьев.
Надеюсь объяснил доступно.
Andreevich
У меня получилось вот что (смотри скриншоты листинга программы и результата работы этой программы):
uses Crt;
const n = 10;
var A: array [1..n] of integer; 
        i: integer;
begin 
ClrScr; 
Randomize; 
WriteLn ( ' Massiv I: '); 
for i:=1 to n do 
    begin     
          A[i] := 1+random(n);  
          Write (A[i]:4); 
    end; 
WriteLn; WriteLn ( ' Massiv II: '); 
for i:=1 to n do 
    begin   
           if (A[i] mod 2 =0) then A[i]:=0 else A[i]:=3*A[i];     
           Write (A[i]:4); 
   end;
ReadLn;
end.     
Составьте программу, которая запол няет массив a [1..10] случайными целыми числа ми в диапазоне от 1
Составьте программу, которая запол няет массив a [1..10] случайными целыми числа ми в диапазоне от 1

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

решить задание по информатике. Массив А из 4 элементов заполняется по формуле. Установите соответствие между формулой и полученным массивом. for x:=1 to 4 do A[x]:=3*x+1; A: 4, 7, 10, 13 for x:=1 to 4 do A[x]:=x*(x+1); A: 2, 5, 8, 11 for x:=1 to 4 do A[x]:=3*x-1; A: 0, 3, 6, 9 for x:=1 to 4 do A[x]:=3*(x-1); A: 2, 6, 12, 20
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

snow8646
Андреевна-Арзуманян1109
StudioArtNails
zverevahelen
Yurevna_Kharkchinov1302
nordwokintos4
Lesya
jenn055
А Дзукаев1562
aregaa
Матвеев
Petrosienko_Larisa,1908
ВалентиновичСуриковна1104
Hugokate77729
besson89