ПетровичЖивотовская1245
?>

1. Составить программу нахождения значения функции у: у=3х+1, если х>0, у=х-5, если х<0. 2. Составить программу решения квадратного уравнения. (Пояснение: все квадратные уравнения отличаются коэффициентами а, в, с, которые участвуют в нахождении корней уравнения, при этом надо помнить, чтобы квадратное уравнение имело корни должно выполняться определенное условие. 3. Составить программу, определяющую является ли треугольник равнобедренным, если известны его стороны.

Информатика

Ответы

Gaziev1636

1)

#include <iostream>

using namespace std;

int main() {

   int x;

   cin >> x;

   cout << "V = " << x * x * x << endl << "S = " << x * x;

   system("pause");

   return 0;

}

2)

#include <iostream>

using namespace std;

int main() {

   double a, b;

   cin >> a >> b;

   if (a > b) {

       cout << "a > b " << endl << a;

   }

   else {

       cout << "a <= b " << endl << a << b;

   }

   system("pause");

   return 0;

}

3)

#include <iostream>

using namespace std;

int main() {

   int x;

   cin >> x;

   if (x % 2 == 0) cout << "YES";  

   else cout << "NO";

   cout << endl;

   if (x % 10 == 3) cout << "YES";

   else cout << "NO";

   cout << endl;

   system("pause");

   return 0;

}

sebastianpereira994

Как организовать ожидание в программе до нажатия какой-либо клавиши? В QBasic для этой цели подойдет системная переменная INKEY$. Достаточно присвоить ее значение какой-либо символьной переменной, например А$, и организовать бесконечный цикл до тех пор пока длина значения А$ перестанет отличаться от нуля:

А$=""

М10 : A$=INKEY$ ; IF А$="" THEN GOTO M10

Можно воспользоваться и другим приемом — включить в программу оператор ввода в какую-либо переменную символьного типа. Такая переменная предпочтительнее числовой, т. к. в нее можно ввести пустое значение, нажав только клавишу <Enter>. Кроме того, набор любого отображаемого символа не приведет к ошибке.

В Си временный приостанов до нажатия какой-либо клавиши организуют с функции getch.

В Паскале можно организовать бесконечный цикл, аналогичный приведенному выше варианту для QBasic, с логической функции KeyPressed:

while not KeyPressed;

var

 N: integer;

begin

 write('N = ');

 readln(N);

 writeln;

 writeln('Цифры числа (справа налево):');

 while N > 0 do { <-- Выполняем цикл, пока число больше 0 }

 begin

   write(' ', N mod 10); { <-- выводим остаток деления на 10 }

   N := N div 10 { <== находим целую часть от деления на 10 }

 end;

 readln

end.

Примеры

Входные данные

3

v 3

l 1

u 2

luvu

3

luv

vul

uuu

Выходные данные

6

11 задание не знаю сорри бро дай корону

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. Составить программу нахождения значения функции у: у=3х+1, если х>0, у=х-5, если х<0. 2. Составить программу решения квадратного уравнения. (Пояснение: все квадратные уравнения отличаются коэффициентами а, в, с, которые участвуют в нахождении корней уравнения, при этом надо помнить, чтобы квадратное уравнение имело корни должно выполняться определенное условие. 3. Составить программу, определяющую является ли треугольник равнобедренным, если известны его стороны.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Vladimirovna1370
schernov
Sacharov84
ВостриковаСтародубцева1980
marketing6
skorykin123371
ВладимировнаАлександр1421
nordwokintos4
Александр1991
mukbidc
mac4roc3781
tsatskina857
museumuzl
Popova-Erikhovich
irina611901