Описание алгоритма:
Будем наращивать длину последовательности от 0 знаков до N. Пусть после какого-то количества шагов у нас выписаны все последовательности длины А и мы хотим узнать количество подходящих последовательностей длины А+1. Распределим все последовательности на три группы(так как предыдущие символы нас не волнуют, то любые последовательности одной группы для нас равнозначны):
1) Заканчиваются на 0.
2) Ровно на одну единицу
3) Ровно на две единицы.
Из каждой последовательности группы 1 приписыванием нуля или единицы мы можем получить одну последовательность группы 1 и одну - группы 2. Неважно, какие именно, но они не перекрываются, т.к. предыдущие символы различны, хоть мы их и не учитываем. Точно так же из второй группы мы получаем одну последовательность группы 3 и одну группы 1, а из группы 3 - только группу 1. Таким образом, если количества последовательностей длины А по группам были (x, y, z), то для длины А+1 такое распределение будет (x+y+z, x, y). Если взять для длины 0 тройку (0, 0, 1) и просчитать тройки от 1 до N, получится искомое количество. Для a=1 и b=2 также работает правильно.
Программа на Pascal:
var num00,num01,num11,mem00:integer;
a,i:byte;
begin
readln(b);
num00:=1;
for i:=1 to n do begin
mem00:=num11;
num11:=num01;
num01:=num00;
num00:=num01+num11+mem00;
end;
writeln(num11+num01+num00);
end.
Объяснение:
извени если ошебусь
:)
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу и составьте блок схему к следующей задаче: с клавиатуры вводится произвольное четырёх значное целое число. найдите произведения цифр числа и разность второй и третьей цифр этого числа
Пользователь знает ключ, или
пароль, который известен только ему. К этой группе можно отнести и идентификацию через смс-уведомления. При вводе имени и пароля пользователя сервер сравнивает введенные данные
с сохраненными данными. В случае полной идентичности введенных данных появляется возможность войти в систему.
Различают два вида паролей – динамические
и постоянные. Постоянные пароли изменяются
только по требованию пользователя, а динамические пароли изменяются по определенным параметрам. Например, если пользователь забудет
пароль, сервер может предложить ему динамический пароль для входа в систему.
Объяснение: