Андрей
?>

Написать программу, которая вычисляет сумму покупки трех видов товаров: тетрадей, ручек и карандашей. Стоимость тетради – 20 руб, карандаша – 3 руб, ручки – 5 руб. Стоимость покупки зависит от количества проданного товара. Предлагаемый вид экрана. Количество тетрадей: 4 Количество карандашей: 5 Количество ручек: 5 Стоимость покупки: 120 руб

Информатика

Ответы

kirillprotopopov1
1
program z;
var
    i : integer;
begin
    Writeln('Введите число'); Readln(i);
    if i mod 2 = 0
        then
            Writeln('Число чётное')
        else
            Writeln('Число не чётное');
    readln;
end.

2
program z;
var
    i : integer;
begin
    Writeln('Введите число'); Readln(i);
    if i mod 3 = 0
        then
            Writeln('Число делится на 3')
        else
            Writeln('Число не делится на 3');
    readln;
end.

3
program z;
var
    i: array[1..6] of byte;
    x:byte;
begin
    for x:=1 to 6 do
   
        begin
            Writeln('Введите ', x,' цифру из 6 ');
            Read(i[x]);
        end;
    if (i[1]+i[2]) = (i[4]+i[5]+i[6])
        then
            Writeln('Билет счастливый')
        else
            Writeln('Билет не счастливый');
    Readln;
end.
       
5)))
program z;
var
    i : integer;
begin
    Writeln('Введите число'); Readln(i);
    if i mod 6 = 0
        then
            Writeln('Число делится на 6')
        else
            Writeln('Число не делится на 6');
    readln;
end.
6
program z;
var
    a,b:integer;
begin
    Writeln('Введите число A'); Readln(a);
    Writeln('Введите число B'); Readln(b);
    if b mod a = 0
        then Writeln('Число А делится нацело на число В')
        else Writeln('Число А не делится нацело на число B');
    Readln;
end.
       
ibswoklol1362
1)
uses crt;
const
n=5;m=7;
var
i,j,s:integer;
a:array[1..n,1..m]of integer;
    begin
       randomize;
       clrscr;       
             for i:=1 to n do       
               begin           
                   for j:=1 to m do             
                      begin                   
                            a[i,j]:=random(40)-19;                   
                             write(a[i,j]:4);             
                      end;           
                    writeln;       
               end;
writeln;
          for j:=1 to m do   
                  begin         
                      s:=0;       
                          for  i:=1 to n do             
                              s:=s+a[i,j];         
                       writeln ('j:',j,' ', s);   
                     writeln;
                  end;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая вычисляет сумму покупки трех видов товаров: тетрадей, ручек и карандашей. Стоимость тетради – 20 руб, карандаша – 3 руб, ручки – 5 руб. Стоимость покупки зависит от количества проданного товара. Предлагаемый вид экрана. Количество тетрадей: 4 Количество карандашей: 5 Количество ручек: 5 Стоимость покупки: 120 руб
Ваше имя (никнейм)*
Email*
Комментарий*