maximovpavel9114
?>

Задание 1. Составить программы на Pascal с комментариями для решения задач: 1.Задать массив случайными числами из промежутка [-15;15]. Вывести его на экран. Все элементы массива, значения которых меньше 10, заменить нулями. Полученный массив вывести на экран. Подсказка: Чтобы задать случайные числа из промежутка [a, b], воспользуйтесь формулой для функции случайных чисел random(b-a+1)+a 2.Подсчитать и вывести на экран сумму элементов каждой строки массива, состоящего из 5 строк и 5 столбцов. Значения элементов массива – случайные положительные и отрицательные числа.

Информатика

Ответы

Varvara
Uses Crt;
  const n=5; m=7;
  type Mas = array [1..n, 1..m] of integer;
  var i, j, j1, j2: integer;
      Sumj1, Sumj2: real;
      A: Mas;
begin
 ClrScr;
 Randomize;
 SumJ1:=0; SumJ2:=0;
 for i:=1 to n do
    for j:=1 to m do
    A[i,j]:=random (10);
 WriteLn (' Massiv A: ');
 for i:=1 to n do
   begin
      for j:=1 to m do
      Write (A[i,j]:4);
      WriteLn;
   end; WriteLn;
 repeat
   Write (' Stolbez #1 = ');    ReadLn(j1);
 until (j1>=1) and (j1<=m);
 repeat
   Write (' Stolbez #2 = '); ReadLn(j2);
 until (j2>=1) and (j2<=m) and (j1<>j2);
 for i:= 1 to n do
    SumJ1 := SumJ1+A[i,j1];
 for i:= 1 to n do
   SumJ2:=SumJ2+A[i,j2];
 SumJ1:=SumJ1/n; SumJ2:=SumJ2/n; 
WriteLn;
WriteLn (' Srednee stolbza ', j1, ' = ', SumJ1:4:2);
WriteLn (' Srednee stolbza ', j2, ' = ', SumJ2:4:2); 
ReadLn;
end.
Паскаль.составить программу, вычисляющую среднее значение по двум столбцам матрицы. номера столбцов
Шавкат кызы
Какие такие графические оболочки?
неужто линукс?

KDE - или кеды, самые дружелюбные к пользователю
пример кедов на скрине (ток у меня специально упрощенный)

GNOME2 - отличная оболочка раньше была, но перешли на кеды, так как на смену пришел GNOME3

GNOME3 - многие плюются, многие восхищаются
кому как, мне лично понравилось, но пробыл с ним 2-3 месяца

XFCE - легкая оболочка, для нетбуков и т.п. - отличная вещь

LXDE - легкая оболочка, однако хоть и легче немного XFCE, но работать с ней - мазохизм

UNITY - столько радужных слов хочется сказать
уж слишком тормозит на древнегреческих компах
уж слишком много ресурсов ест
уж слишком много анимации
+ не удобное меню
используют его как правило ламеры/хомячки которые сидят на бубунту, и не знают, что есть другие оболочки

Отличаются как правило - заводскими программами при установке

Чем различаются типы графических оболочек
Чем различаются типы графических оболочек

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задание 1. Составить программы на Pascal с комментариями для решения задач: 1.Задать массив случайными числами из промежутка [-15;15]. Вывести его на экран. Все элементы массива, значения которых меньше 10, заменить нулями. Полученный массив вывести на экран. Подсказка: Чтобы задать случайные числа из промежутка [a, b], воспользуйтесь формулой для функции случайных чисел random(b-a+1)+a 2.Подсчитать и вывести на экран сумму элементов каждой строки массива, состоящего из 5 строк и 5 столбцов. Значения элементов массива – случайные положительные и отрицательные числа.
Ваше имя (никнейм)*
Email*
Комментарий*