const
n=10;
type
mas = array [1..n] of real;
procedure search(massive : mas);
var j : integer;
max, min : real;
begin
max := 1;
min := 1;
for j:=1 to n do
begin
if massive[j] > max then
max := massive[j];
if massive[j] < min then
min := massive[j];
end;
writeln;
writeln('наибольший элемент: ', max);
writeln('наименьший элемент: ', min);
end;
var
i : integer;
a : mas;
begin
writeln('введите массив: ');
for i:=1 to n do
read(a[i]);
writeln('массив: ' );
for i:=1 to n do
write(a[i]:4);
search(a);
end.
Объяснение:
Родился в 1950 г. Калифорния, США.
Джон Уокер - программист, автор и соучредитель компании Autodesk, специализирующейся на компьютерном проектировании. В последнее время он был признан за его записи на Fourmilab.
В 1974/1975 годах Уокер написал программное обеспечение ANIMAL, которое самостоятельно воспроизводилось на машинах UNIVAC 1100. Он считается одним из первых компьютерных вирусов.
Уокер также основал компанию по производству аппаратной интеграции Marinchip. Среди прочего, Marinchip был первым, кто перевел многочисленные компиляторы компьютерных языков на платформы Intel.
В 1982 году Джон Уокер и 12 других программистов объединили 59тыс долларов США для запуска Autodesk (AutoCAD) и начали работу над несколькими компьютерными приложениями. Первым завершено было AutoCAD, программное приложение для автоматизированного проектирования (CAD) и черчения. AutoCAD начал свою жизнь как InteractCAD, написанный программистом Майклом Риддлом на проприетарном языке. Уокер и Риддл переписали программу и заключили соглашение о распределении прибыли для любого продукта, производного от InteractCAD. Впоследствии Уокер заплатил Риддлу 10 миллионов долларов США за все права.
К середине 1986 года компания выросла до 255 сотрудников с годовым объемом продаж более 40 млн.долларов. В том же году Уокер подал в отставку с поста председателя и президента компании, продолжая работать программистом. В 1989 году была опубликована книга Уокера «Файл Autodesk». Он описывает его опыт работы в Autodesk, основанный на внутренних документах (особенно электронной почте) компании.
Уокер переехал в Швейцарию в 1991 году. К 1994 году, когда он ушел из компании, это была шестая по величине компания по производству программного обеспечения для персональных компьютеров в мире, в первую очередь благодаря продажам AutoCAD. В то время Уокер владел около 45 млн. долларов.
Fourmilab
Он публикует в своем личном домене fourmilab.ch, предназначенном для игры на Fermilab. На своем веб-сайте Уокер публикует информацию о своих личных проектах, в том числе об аппаратном генераторе случайных чисел под названием HotBits, а также о программном обеспечении, которое он пишет и свободно распространяет, например, о программе просмотра Земли и Луны. Другая известная статья называлась «Хакерская диета».
Одна особенно заслуживающая внимания статья была озаглавлена «Цифровой имприматур: как старший брат и крупные СМИ могут вернуть интернет-джинна обратно в бутылку», статья об интернет-цензуре, написанная в 2003 году. Он был опубликован в журнале «Знания, технологии и политика». В статье Уокер утверждает, что усиливается давление, ограничивающее возможность пользователей Интернета высказывать свои идеи, а также прогнозировать дальнейшую цензуру в Интернете. Уокер утверждает, что наиболее вероятным кандидатом на вступление в то, что он называет «цифровой авторизацией», является управление цифровыми правами, или DRM.
Поделитесь своими знаниями, ответьте на вопрос:
Составьте программу, удваивающую значение целой переменной а, если а<10 и утраивающую значение переменной, если a>=10.
Язык программирования Python
a = 1 # Пусть a = 1
if a < 10: # Если a меньше 10
a = a * 2 # Удваиваем
if a >= 10: # Если а больше или равно 10
a = a * 3 # Утраиваем